Horrendous FPS drop in Multiplayer vs Single Player

:arrow_forward: GAME INFORMATION

  • Build: 101.101.37906.0 5105673
  • Platform: Steam
  • Operating System: Windows 10 Ver 1903
  • Gamertag: Darrxy

:arrow_forward: ISSUE

In a typical online game I sit at 144 fps for around the first 10-15 minutes. Gradually the FPS drops off during the next 10-15 minutes until it sits at around 25 FPS. Once it drops below 60, I start noticing an increased delay in unit commands. I’ve tried this with just AI on multiplayer and with a friend.

It’s worth noting that doing exactly the same game in single player doesn’t have the same performance hit. I can maintain at least 60 FPS in single player using exactly the same settings as online.

:arrow_forward: REPRODUCTION STEPS

Create any multiplayer game with AI. The issue doesn’t appear to care for the server the game is hosted on nor any mods or map types. I’ve also tried turning down the graphics settings whilst in-game and it hasn’t made any difference.

:arrow_forward: GAME FILES

Single player replay for reference - https://drive.google.com/file/d/1dtyw0wwwb5nDfI3c2H0V_d2YLwIOk8ya/view?usp=sharing

Multiplayer replay - https://drive.google.com/file/d/1U64ETTwzyVLQe5svER3vAIhl5X2ut6Xi/view?usp=sharing

:arrow_forward: IMAGE & ATTACHMENTS

Single player recording - https://www.youtube.com/watch?v=M-vMvO9oJdQ
Multiplayer recording - https://www.youtube.com/watch?v=KFdBHyRs_Rc

Specs:
Resolution - 3440x1440 @ 144Hz
CPU - Intel i7 8700k running at 4.2GHz
RAM - 16GB DDR4 2666MHz
GPU - Gigabyte gaming OC 2080
Storage - 1TB Sandisk SSD
Internet - 72Mbps down/19 Mbps up
GPU driver - Ver 446.14

2 Likes

I have absolutely the same issue that exists only in multiplayer but not single player. My resolution is 2560*1440 at 144Hz. So far no real answer.

What was the ping by chance for the players in the game?

My ping whilst doing the test game was 22ms.

My friend also has the same issue when hosting, but he’s running a 9900k and a 2080ti

1 Like

I was going to edit my original post but I can’t find the option on my mobile, but it appears the issue is strictly limited to the host of the game rather than other players.

My friend and I are trying to find different things to test, but would be good to get a little direction from the Devs. I’m itching to see a resolution to the issue so I’m happy to test various things to narrow down the problem.

I also have this issues in Sep 2020. Played 3 v 3 with a friend + AI against 3 AIs. Singleplayer constant 144 FPS but in MP it just drops to 20 and stays for a few minutes. Unplayable and I haven’t seen any resolves on this topic either <.<

A 2d game with almost the same mechanics as the 1999 version performing badly on modern gaming computers… It’s insane! I think they need to measure exactly which feature is using how much CPU, GPU, RAM and disk resources on some standard machines, and then try to optimize or remove said features…
Some basic things like an option for a fps cap (the original game was constant 20fps) and the possibility of importing graphics on the same level as what the original had would probably fix performance for everyone I assume, without the complexities of trying to track down what was it that was done to break the game performance like this.