Hosting of games through Create Lobby inconsistantly not working

Game Version:

  • Build: 101.101.36202
  • Platform: Steam
  • Operating System: mainly Linux Ubuntu 18.04, but had similar issues on Windows 8.1 before crashing
  • Gamertag: mastermystery


When I host a lobby via create Lobby, it does not appear on the Lobby visible to other players. I can still invite my friends though, but they also do not see it in the Lobby. I have checked the lobby settings and set to public (upon hosting) and the visibility once in the game. Neither changes this. This happens in 24 out of 25 cases and up to know I have tried around 200 times to host a game. But it is not 100% reproducible very seldom (<5%) it does work and then the game us full and joined by people within seconds.

Reproduction Steps:

Here’s how to reproduce the problem:

  1. Host normally with default settings
  2. Host with server set to westeurope (as this is the server which i see most of the time, cross visibility occurs only a few times actually for me)
  3. deactivate or active spectators
  4. 2+3

It does not work with either tries consistently, though it has worked once with default and twice with westeurope with and w/o specators. But it cannot really be that i have to have 20+ tries to host until it is hosted and visible

Bonus: matchmaking works just fine. (for my main playing friend it is exactly the same issue)