Hotkeys completely broken

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: ######
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

So, testing since yesterday my hotkeys are just completely broken.

The vast majority of hotkeys have been reset to default (except for once that were occupied by F keys or extra mouse buttons). I cannot change my hotkeys while in a match. I can change them in the menu, but if I then try to change them in a match, it resets ALL keys back to default. I then went to change all my hotkeys back in the menu, and it worked for a few matches. I did backup the hotkey files, just in case it resets again. Io and behold, I log in today play a match and have again default hotkeys. I try to copy in the hotkey file from the backup and nothing changes. I try to copy over the hotkey files from a friend’s account and the hotkeys are still all default hotkeys. I login to a friends account and hotkeys work fine.
So it oddly enough seems to be an account based issue.

Edit: Nvm, restarting the game on a different account will reset hotkeys as well. Only the first start worked.


Hi @MustySnizl
How many hotkey profiles do you have? Can you delete the ones you don’t use(if you have more than one), just to make sure the game is not switching between them?

Im just having the default and one custom hotkey profile.
Which file does the hotkey profile require? .hki, .hkp, or both?

I recommend you to try some stuff:

  1. Deleting your user files. For deleting your user files, you should:

a. Make sure that your Steam Cloud is disabled in Steam, AoE2 game, Properties, General.

b. Go to C:\Users\YOUR_USER\Games\Age of Empires 2 DE.

c. Copy your user folder to a safe place, it has lots of numbers.

d. Delete the original folder

e. Verify your files in Steam, AoE2 game, Properties, Local Files.

f. Open the game again. A new user folder will be created.

If this works, then copy back the files from your old user folder. Those files are in the folder -C:\Users\YOUR_USER\Games\Age of Empires 2 DE<0>\Savegame, Recorded Games and Save games.

This seems to have worked for now. Will see if it will remain fine.

edit: still working fine so far.

1 Like