Hotkeys reset when I restart the game

Game Version: 101.101.32708.0.0

  • Platform (Microsoft Store)

I set all my Hotkeys and was able to play with them, but when I close the game and start it again, my Hotkeys are always the standart ones again. I also tried to use a new Hotkey Profile, but that did not help at all.

Reproduction Steps:

  1. Set new Hotkeys
  2. Confirm them
  3. Close and open the game
  4. Check Hotkeys

Picture ( I know that it is probably not helpful)

Got the same problem and got rid of that. Not sure what cured the problem so here we go :

  • Found the config files in [%USERPROFILE%]\Games\Age of Empires 2 DE,
  • Tried to import hotkeys from HD Edition because why not,
  • Didn’t work, restarted the game a couple of time and nothing changed,
  • Deleted the config files and unchecked “read-only” on properties,
  • Restarted the game. Every profiles were deleted BUT MY HD PROFILE. No idea why. Everything was off tho, so I had to rebind everything.

The folders are back on their “read-only” state but at least I can finally change my hotkeys.