How can I play Age of Empires III online? Keeps saying invalid key code


#1

I bought AOE III at Amazon and got invalid key code, got one from Walmart and got the same error so I returned the one from Amazon and got a 3rd disk and got the same error. I contact Microsoft and they tried everything but said looks like its the creators issue and I have to wait for them to resolve the issue but looks like there still may be good key codes out there. Tried download online too and saw they were having same issue, like there is bad batch of key codes out there. Does anyone have a old valid key code or how I can get online?


#2

Hello, you need to buy the digital version on Steam, that is the only place where the game is officially distributed nowadays with valid CD keys pretty much ensured: https://store.steampowered.com/app/105450/Age_of_Empires_III_Complete_Collection/


#3

See notice on 04/30 and then I saw comments in August asking when they were going to resolve. I just want to get online. I use to play this game 10 years ago. Does any one have extra game or code?

APRIL 30

ESO multiplayer service temporarily unavailable

We’re sorry to share that the multiplayer service for Age of Empires III is temporarily unavailable. We are working to resolve this and get the ESO service back up and running. We don’t yet have an estimate on when that will be, but we expect the time frame to be measured in days, not hours.

We’re truly sorry for the inconvenience, and look forward to getting you back to your home cities as quickly as possible!

Follow us on Facebook and Twitter for the latest updates; we will share more information whenever we have it!


#4

The issue mentioned there lasted for one weekend in April.