How do I enable Multiplayer?


#1

When I run the game, the Multiplayer button is toggled off.
The official support page was to no help to me. I’ve forwarded the required ports and I’m logged into my Xbox Live account before running the game, and in fact I’m even able to view my profile from the game client. Despite that, the tooltip I get is “No Xbox Live service connection”.
How do I make it work?


#2

Do run additional antivirus software?
And if so, which brand and version.


#3

I have Kaspersky Anti-Virus 18. I’ve also tried to disable the protection before running the game, but to no use.


#4

Does it have options to disable firewall and or exclude folders from real-time scanning?


#5

As I just said, I’ve already tried that but it was useless. I even tried to entirely close the application.


#6

You have tried with completely uninstalling the Kaspersky antivirus application?


#7

No… wouldn’t that be excessive, though? Once I close its related process I don’t think it interferes anymore with the game or anything else.


#8

Well, there are differences between just disabling or excluding and completely uninstalling including reboot.

I would look into this thread for a solution.
https://forum.kaspersky.com/index.php?/topic/364253-kaspersky-internet-security-2017-blocks-xbox-app-on-windows-10/


#9

There are also big difference between Kaspersky Antivirus 2018 and Kaspersky Internet Security 2018. So if you are mistaken in the version the procedure probably will be different.

In general it should be enough to exclude the complete AOE DE application folder or the AoEDE.exe process.

The easiest way to get the current version application folder name is to launch PowerShell and type:
(Get-AppxPackage *MSDallas*).InstallLocation


#10

I don’t have Internet Security, so I can’t deal with Kaspersky’s firewall and the likes.


#11

Exclusion of folders and processes should be possible with every version of Kaspersky. I would look into the options there anyway and try anything that looks suitable to me regarding this block.

Did you also check the current Windows firewall rules?


#12

Well, so:

  • Windows Firewall looks alright (the game was already among the allowed apps list)
  • The folder I got through the PowerShell command has been added to the exceptions on Kaspersky
    …but the issue remains.

#13

Okay, that’s a pity.

Now please check all the rules starting with Xbox below outgoing connections in Windows Advanced Firewall.


#14

I have the following enabled: Xbox, Xbox Game bar, Xbox Game UI, Xbox gaming overlay, Xbox Identity Provider, Xbox TCUI.


#15

Looks fine to me.

Except for excluding folders, is there also an option to exclude processes in Kaspersky?


#16

I can only exclude folders or specific files. I think the folder exclusion should be inclusive of the files inside (and I can’t really browse inside the WindowsApps folder as it’s protected).


#17

Maybe if you right click Kaspersky and choose launch as administrator you can browse inside the folder by pasting the PowerShell folder name in the folder path selector of Kaspersky file browser control.

Also please check the following. Disable self defence. And I would like to see what’s below network.
https://support.kaspersky.com/13949

Did you reboot after adding the folder exclusion. Sometime one extra reboot makes a big difference.


#18

A long shot here but how much time did you wait to see if it connects? Because my multiplayer button is enabled (becomes blue) after about 10 seconds, before that it says “no Xbox live service connection”.


#19

He does sound impatient, but it’s not the case. Looks like something is blocking and I can remember issues with Kaspersky before. But they have so many different antivirus crap versions.

So many problems, so little time. :wink:


#20

@PCS70
Ok, so I did a reboot. I managed to add the executible to the exceptions through direct path pasting as you suggested and I disabled self-defense. Under network I have the following:
Cost-Aware Networking: Limit traffic on metered connections
Traffic processing: Inject script into web traffic to interact with web pages
Monitored ports: Monitor selected ports only
Encrypted connections scanning: Scan encrypted connections upon request from protection components

@IamDalv
Actually, it takes about 10 seconds to turn the green button at the top from “Profile” to my Xbox Live username. Nothing happens with the Multiplayer button.