How do I enable Multiplayer?


#21

The last three are very interesting. Could you check them?
You might want to post some screenshots.

Also if you launch Xbox app and go to settings and then network tab, what does it say?


#22

Internet Connection: Connected
Xbox Live Services: Operational
Xbox Multiplayer
NAT type: Open
Server connectivity: Connected
Performance
Latency: 29 ms
Packets loss: 0%


#23

Hmm, very strange issue we got here. According to Xbox app everything is fine. Yet I would try to disable scanning of encrypted connections and also disable the script injection in web traffic.

And check below network ports if the Xbox ports are listed there and disable monitoring.

And the following ports need to be added there too I guess.

  • Port 3478 (UDP & TCP)
  • Port 5222 (UDP & TCP)

At least we can revert back all changes as everything is logged here. And don’t forget to reboot after adding those ports. :slight_smile:


#24

Argh, still no good.

In reply to #25
I’m editing this post because apparently
“You’ve reached the maximum number of replies a new user can create on their first day. Please wait 18 hours before trying again.”
And the fun is double when you realize I’ve been an user since March 2018! lmao

@PCS70 Anyways yes, I followed all your instructions.

PS C:\WINDOWS\system32> Get-WindowsOptionalFeature -Online -FeatureName DirectPlay

FeatureName      : DirectPlay
DisplayName      : DirectPlay
Description      : Enable DirectPlay installation on request.
RestartRequired  : Possible
State            : Disabled
CustomProperties :
                   ServerComponent\Description : Direct Play Component.
                   ServerComponent\DisplayName : Direct Play
                   ServerComponent\Id : 488
                   ServerComponent\Type : Feature
                   ServerComponent\UniqueName : Direct-Play
                   ServerComponent\Deploys\Update\Name : DirectPlay

PS C:\WINDOWS\system32> netsh interface teredo show state
Teredo Parameters
---------------------------------------------
Type                    : disabled
Server name             : win1711.ipv6.microsoft.com.
Client update interval  : 30 seconds
Client port             : unspecified
Status                  : offline
Error                   : none.



PS C:\WINDOWS\system32> netsh interface teredo show state
Teredo Parameters
---------------------------------------------
Type                    : disabled
Server name             : win1711.ipv6.microsoft.com.
Client update interval  : 30 seconds
Client port             : unspecified
Status                  : offline
Error                   : none.

PS C:\WINDOWS\system32> winver
Windows 10
Microsoft Windows
Version 1803 (build SO 17134.523)

@PCS70 In reply to #26
I’m getting this error message:

Enable-WindowsOptionalFeature : Impossible to read the Registry key of the system.
In line:1 car:62
+ ... nline -FeatureName DirectPlay | Enable-WindowsOptionalFeature -Online
+                                     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Enable-WindowsOptionalFeature], COMException
    + FullyQualifiedErrorId : Microsoft.Dism.Commands.EnableWindowsOptionalFeatureCommand

@PCS70 In reply to #27. I managed to add DirectPlay and got really excited for a moment, but unfortunately Multiplayer is still not working.


#25

You did disable scanning of all those and used Xbox ports?

Two more things to check.

  1. Run PowerShell as administrator and type following:
    Get-WindowsOptionalFeature -Online -FeatureName DirectPlay
    And:
    netsh interface teredo show state

  2. Launch PowerShell normally and type again:
    netsh interface teredo show state
    And:
    winver

Please post back all results. Only two more things left to try and check before I’m out. :wink:


#26

Great info. Let’s add DirectPlay and after that reboot your computer again.

To do so launch PowerShell as administrator again and type the following:
Get-WindowsOptionalFeature -Online -FeatureName DirectPlay | Enable-WindowsOptionalFeature -Online


#27

Okay. There is another method.

Open control panel and go to programs and click on ‘Turn windows features on or off’. There unfold ‘Legacy Components’ and enable checkbox for ‘DirectPlay’. Click on OK and after process finished reboot your computer.