HRE conversion?

Has anyone had any luck adding the single target conversion ability to another civ? I cloned the abbasid ability, added it to the sbps for the hre monk, and removed the requirements for the tech to be researched. And it sort of worked.

The ability shows up as normal, except when i click on a unit to convert it throws an error saying “too close” I have looked through all the requirements and errors and I am not seeing this error. Anyone know what I am doing wrong?

Update! I found that the sbps of the HRE monk is missing targeting. I added that, and the ability can now be targeted. However, I ran into a further issue. The ability doesn’t actually convert when its used. :frowning:

I suppose there is logic here:
<state_tree_node name=“ability_activate_deferred_tree” value=“monk_conversion_faith_abb” />

that is guarded. However, attempting to go to the reflect value doesnt bring up the data. This is straight up missing. Please devs, give us these abilities to work with. :frowning: