Huge stutters with black FOG, undiscovered + map borders RX570

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 101.101.43210.0 5867313
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

After many tries I get to reproduce somehow the stutters I get with the latest patch…
I got huge stutters when there is black fog (undiscovered or maps borders) in the screen.
I got the same stutters when I do a complete zoom in the map.
Finally, when there are a lot of water, it lags too…

Seems to switch a lot between 150fps and 60 and so it’s not playable correctly.

The funniest thing is that the Xbox game bar can’t record when there isn’t stutters. It shows an error when trying to record (see picture)… but it works when the game lags ??? Anyway with the Xbox game bar disabled this bug is still present so this is not related.

Intel i7 8086k 4.8ghz
32 gb RAM
Bench : 1252.7

This was not the case with the previous patch…
Nothing is running in background except Windows services, Steam and AMD Driver.
Reinstalled the game, previous drivers (before the patch), integrity ok, no mods, … same.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Watch the black fog
  2. Watch the black borders of the map
  3. Zoom in at max level
  4. Watch a lot of water

:arrow_forward: EXPECTED RESULT

No Stutters with an AMD RX570 4gb, I7 8086k 4.8ghz, 32gb SSD NVME

:arrow_forward: IMAGE

Borders : Stutters

Black fog (undiscovered) : Stutters

Marco (with and without polo) : NO Stutters (you can see the error when I typed marco)

Low rez + zoom (I also tried with all options to low) : Stutters

Lot of water : Stutters

Full zoom : Stutters

:arrow_forward: GAME FILES (SAVE / RECORDING)

I can’t record when it’s running fine… the problem is in every game I play. Here is a laggy one, the record smooth up a bit. We can see ~100 fps at the upper left, but it’s not the case with all the stuttering. When there is no stutterings I’m at 150 fps very fluid, no stutters at all (like before).

Thanks for your help, I play this game since 99 (first PC game), I bought all age of things since, even the new DLC. I hope this will be corrected for me.

Have a good day.

After a lot of tests… I think when I left AOE2 DE (return to windows) and go back on the game the stutters appears…

The GPU is used a 75% max. CPU is 20% max lol.

Latest AMD drivers 21.1.1 doesn’t change anything.

they released an update which was earlier today, try again see if anything changed

This new update is great for me ! I get from 100fps to 240fps, same settings, what the…

However it’s not perfect, I think the bug is still here for me, moving with the mouse is still stuttering, but due to the fact I got doubles FPS, I see it less.

Maybe because my graphic card is now 90-100% ?!? Or the 4GB of the graphic card may be limited today in terms of textures ?

I have had the moving mouse stutter issue for awhile, I think its a 3rd party program causing it. for me it was a recording program that I use and disabling it makes it all better.

RX580 and AMD Ryzen 5 3600 here. Same issues with stuttering on menus and in game. GPU is 80% in game, 100% on menus. Runs fine in windowed mode if I hit alt+enter (albeit at 80% GPU still), but when I hit alt+enter again to return to full screen the issue is back. Placing graphics settings on low and following the guide on getting AOE II DE to run on high end PCs in the FAQ on this site have no effect.

Edit: My issue was resolved by disabling Xbox Game Bar recording. For anyone who is also seeing high GPU usage using an AMD RX### card, these steps may help you.

  • Windows key + G
  • Click settings cog at the top
  • Select “Capture”
  • Disable all recording options for audio and video

GPU usage now sits at a reasonable 40%

Desactivated in my case doesn’t change anything but it may be a hint ?

Ok so my game is lagging again… no xbox bar, GPU not at 100% neither the CPU… I don’t understand.