Indian campaign fully unlocked when completing "Pirates!" mission in first campaign

When I access the newprofile xml and go down to those three lines the value is already zero. I put a 1 in those three lines, booted, then put them back to zero but the false progress is still there. Additionally, I do not have an Asian Dynastises folder in my files:


Is there supposed to be one there? Could this be the cause of the bug?

1 Like

Confirmed this happened when the game crashed for me. Had to use “This Is Too Hard” cheat to get past “PIRATES!”

1 Like

Thank you for the help!!! :smiley:

Using the cheat let me pass through the PIRATES! mission but the fake progress in the indian campaing still the same.

I also have beat the PIRATES! mission again to avoid any conflict regarding to the achievements, but the problem persists sending me to the “Company confrontation” mission from the indian scenarios.

We could use some help from the guy who code the sourse to adjust some values.

I’m dissapointed and I don’t kow if I should ask for a refund. :expressionless:

1 Like

Hi BrotherRay9277,

I also don’t have an Asian Dynasties folder in my files.

I will also share you my newprofile file, so you can test out what happens if you replace yours with mine(Make sure to make a backup of your own, just in case!)
here is my file(it’s in the Google Drive):

Step 1: Navigate to C:\Users\MainAcount\Games\Age of Empires 3 DE\76561198057049427\Users and replace your newprofile with mine.

Step 2: Boot the game and check if it changed anything.

Hope this helps you!

Yours Truly,
MainAkkount

Hi @Moteados,
Did you also preform my earlier tutorial, see Step 8. If you scroll up you will find another tutorial which should take away the progress in Asian Dynasties, but keep your progress in Blood, Ice and Steel. If you can’t find it, ill quote the post for you :slight_smile:

Yours Truly,
MainAkkount

When I put your file in it shows a different home city and campaign progress, but when I open the file there are still zeros for campaign progress in your file. You have actual numbers right? It seems like campaign progress is being saved elsewhere for me. I thought maybe through my xbox live account somehow, but then why would it change when I drop in your file? It’s really baffling.

EDIT: I just noticed when I put your file in it changed the continue mission to “changing the guard” from the Indian campaign even when I put my file back. Again, bizzare and I can’t logically think why that would be happening.

1 Like

File:
My file has these numbers(ther dots shouldn’t be there, but the Forum doesn’t display the lines without them):
<.Setting Name=“gamecampaignselected”>0</Setting.>
<.Setting Name=“gamecampaignprogress”>8</Setting.>
<.Setting Name=“gamecampaignfarthest”>8</Setting.>
<.Setting Name=“gamecampaignprogress1”>0</Setting.>
<.Setting Name=“gamecampaignfarthest1”>0</Setting.>
<.Setting Name=“gamecampaignprogress2”>0</Setting.>
<.Setting Name=“gamecampaignfarthest2act1”>0</Setting.>
<.Setting Name=“gamecampaignfarthest2act2”>0</Setting.>
<.Setting Name=“gamecampaignfarthest2act3”>0</Setting.>
<.Setting Name=“gamecampaignshownhcnote”>true</Setting.>
<.Setting Name=“gamecampaignshownhcnote2”>false</Setting.>
<.Setting Name=“gamecampaignshownhcnote3”>false</Setting.>
This is what it says for me:

Sad to see that my fix doesn’t seem to work, I had good hopes, but it seems there is more going on than I thought at first.

Happened to me also. After completing the Pirates mission I got switched to Asian Dynasties.
Reloaded the mission and used the cheat. Received the correct mission on second try

2 Likes

I just thought I’d throw in my bit of information cause I had this bug occure as well but not quite in the same way as the rest of you. I have not actually finished “Pirates!” yet, instead I started the mission and then decided to play it later and closed out of the game. Then, I came back to the level the next day via clicking the “Continue” button on the Main Menu (not through a save file) and then the bug occurred as everyone else has described it including that when I then quit out of the mission I had the Indian Campaign mostly unlocked/completed. I only bring my situation up because I was wondering if maybe the “Continue” button may be the cause of the issue?

1 Like

—SOLVED— thanks to @MainAkkount, follow the tutorials above and don’t use the cheat, worked in my case, read below for details

I can’t remember exactly what happened but I think I went to continue into the 4th or 5th mission in Act 2 ‘Ice’ of the main game and it displayed a loading screen talking about Delhi and featured an Indian character.

The next cinematic ‘Headed West’ loaded correctly, sort of, it did the same softfreeze thing, stopped progressing after a shot of John and Kanyenke running through some daylit grass, similar to the ‘Reunion’ cinematic bug that I’ve seen has already been reported, so I then closed the game and rebooted to latest mission that I had unlocked in ‘Ice’ (skipping the cinematic).

After finishing that mission and the clicking through the ‘You Are Victorious’ splash, another Indian loading screen displayed, which then loaded me into an Indian level. Closed out of the game and rebooted, went into story mode to see that I had 32% completion in Asian Dynasties and the entire India section completed/unlocked, when I haven’t even touched anything other than Act 1 and 2 of the main game.

EDIT!
Under Blood, Ice And Steel where it says Continue, it loads with the Indian loading screen as I’ve mentioned, it then loads into ‘Respect’ correctly… even though I’ve just spent the last hour playing through that mission. I’m not gonna play through it again to test it but I assume it would do the same thing that it did before and others seem to be experiencing, loading the final Indian mission.

Followed the 2nd tutorial above and when using the ‘This is too hard’ cheat in Respect, it progresses correctly to the next level involving Warwick, however all my cards are gone, as well as my home city improvements and XP with my level set back to 1. I can go back to previous levels and all my improvements etc are still there, but as soon as I get to Warwicks Stronghold, it’s all reset to 0. Thought this might be a feature of the game but looking at old playthroughs on YouTube, that doesn’t seem to be the case.

EDIT 2:
Decided to blitz it through ‘Respect’ without using the cheat and I progressed through to ‘Warwicks Stronghold’ with all my progress intact. So in my case I can confirm that after following the above 2 tutorials, some extra time and maybe some other fidling around, I’ve managed to progress normally, keep my home city progression and reset my Asian Dynasties progress, thanks MainAkkount <3

1 Like

I’m also experiencing this bug. I hope it gets fixed soon :slight_smile:

PS. What’s the best “TL;DR” solution for now?

1 Like

Hi YouSeaSwim,
I think the best solution is following my tutorials and to take what CJBA1LEY into consideration

That is indeed a possibility

Thought I’d just tag this on too, but when I went to do MainAkkount’s tutorial here to reset my Asian Dynasties progress these were the values already in that folder. image
Negative values in this section are probably a big no no.

1 Like

Found another thing I wanted to tack on.


The filename values are both right but the scenarioname, campaignscenarioid, and possibly the campaignscenarionameid values are all wrong.
This is after I fixed my progression so now I’m on Mission 4 “Ottoman Fort”.

1 Like

Are you sure you’re in the Campaign Settings? The values for the current campaign mission are in every section of the file (including multiplayer settings) and they should be zeroes everywhere but in the Campaign Settings so make sure you’re in the Campaign Settings section.

1 Like

@MainAkkount I managed to fix my ability to progress using the cheat code and was able to reset my Asian Dynasties progress but upon loading the backup I was unable to recover my Home City progress.

I did a pre order to play the campaign and now more than 1 week after the launch this bug is still there, this is unacceptable

1 Like

Hello everyone! A potential fix for several campaign issues were integrated with Thursday’s update (3552)! If you are still experiencing this particular issue, please let us know ASAP so we can take a closer look at why this specific scenario is skipping to the incorrect mission.

Thank you for all of your reports!

1 Like

I retried the mission and it allowed me to progress properly. tyvm