Installing the Original AOE games on a Windows 10 PC

@AnotherRiddle said:
My original version of AOEIII works fine on Win 10 but I couldn’t play ESO. I ended up buying the latest version, also from Steam, and can now play multiplayer :slight_smile:

I haven’t played so new game yet :slight_smile:
AoE 1 Trial versions/Demos do need compatibility if not isntallig properly, what I’ve played endlessly.

AOE 1 - just download and run from windows explorer. No need of any installation. AOE II and AOE III, I did install without any compatibility mode, it just worked fine.

I am own the Ubisoft Release, too and tried to install AoE plus Burning Rom on Win10. It works very well, if you use some help but AoE runs without compatibility mode this why it is easy.

  1. Going to install Age of Empires plus Expansion Pack, without Administration rights or compatibility mode
  2. Download from Internet the Age of Empires Upatch, a fan patch to update the games with higher resolutions and so on and it fixes some compatibility issues, than run it normally. Follow the instructions
  3. Go to the Programs and Features window from Windows 10 (you can find this menu in the applications menu of the settings) and activate everything under “legacy components” with DirectPlay , wait a second
  4. Start the game

mine Age of Empires and rise of Rome installed and ran fine on windows 10 AOE ii did not install I used the run as admin that seemed to work

I installed AOK Gold edition on my windows 10 laptop and was able to run it in XP compatibility mode. The colours are a bit off but other than that it runs fine. You have to run as administrator and turn off UAC though. You could always dual boot with Linux and run it through wine if windows is having issues with running it, but that has some drawbacks and is harder to set up.

Aoe 2 runs fine and look great using the unofficial 1.4 patch from the internet.

It depends a lot on the hardware to have, most issues I encountered are driver related. Haven’t tried with my current PC, but on my old one they worked all fine.
Also, installing the unofficial patches for Age1 and Age2 make things a lot smoother:
Age1: http://upatch-hd.weebly.com/
Age2: http://userpatch.aiscripters.net/

I’m not sure if they remove copy protection of the games, if you don’t have an optical drive anymore you need a different solution. I used cd images for years, to save my CDs from getting even more scrated and probably brake at some point.

An Alternative would be to wait for the next sale on Steam, I did that and bought them heavily discounted. Try the Age of Empires Legacy Bundlen with Age 2HD and Age 3, with all Addons. A bit more is the Microsoft RTS Collectio with Age 2HD, Age 3, AoM EE, RoN EE and Halo Wars 1 with all Addons.
http://store.steampowered.com/bundle/2185/Age_of_Empires_Legacy_Bundle/
http://store.steampowered.com/bundle/2148/Microsoft_RTS_Collection/

The dates for the next sales are alread leaked, its 22nd to 28th November and 21st december to 4th january.

Most important to be able to play older games on Windows 10 is that you install DirectPlay through control panel -> software -> add/remove components. Just scroll down to older components, unfold it, mark the checkbox and click OK to install it. Also you need to run it in compatibility mode and like @Sok4R said you could use the unofficial patches too.

I bought the original CD version–again–i found it at a GoodWill–sealed. I installed AOE II Kings and Conquerors expansion. Ran the Age2XPatch and the UserPatch v1.4 setup with no hiccups. On the first run–the splash and intro video began…then crashed. I cannot start the game. i have run in compatibility mode for all going back to like 98. What do I have to do yo? help! This was my favorite game for the longest and if I go the Steam route–it would be like the 3rd time I purchase the same game! LOL…i dig it but not that much.

@ilsaltimbanque

Before running the Age2XPatch.exe patch, did you run the Age2upA.exe patch first?

I would check first if the game can run already after those two before applying the UserPatch 1.4, also UserPatch version 1.5 beta is available at the moment.

Compatibility mode need to be set on age2_x1.exe to Windows XP (SP3) and mark “Disable visual themes”, “Disable desktop composition”, “Disable display scaling on high DPI settings” and “Run this program as an administrator”.

If you have a problem with graphics and strange colors, you will need to kill the explorer through the task manager before launching a play and start it again after finished playing AOE II. I did make a script for this once way back in time. Now I play the AOE II HD Edition from steam, it doesn’t have all those problems.

I use UPatch to make AoE 1 work.
I couldn’t get AoE2 original to work, so I bought HD. It’s worth it though - gameplay is not changed (other than minor balance changes) and there are a load more civs.

I’ve gotten mine to work thanks to Compatibility Mode (thank you microsoft :smile: )

FWIW, I’ve had the original AOE installed on my Windows 10 system and working fine since the Windows 10 Beta was released. Run the game as administrator to fix a lot of the lockups. Do not expect AOE to do full screen or high def on new systems or large monitors. I have installed from the original game, the collectors game, the AOE/ROR set and copies of those discs on every Windows OS that has come out (and play AOE a half dozen times a week still).

My current install is the original CD purchased new at the Microsoft Store in 1997. :slight_smile:

Jeff

@Telperinquar said:
Just to get in the mood for a AOE reboot I thought I’d try and install the original games on my windows 10 PC, I didn’t get very far, does anyone know if they will work?

I have Age of Empires Gold Edition and they work just as well for me on Windows 10 as they did on Win 95, Win 98 and XP.

It was Vista and 7 that seemed to have it’s problems but there was still a fix for that.

Also get the UPatch HD as it’s great and it’s what DE is based on.

Hi, i’m new here and i cant speak english very good :smiley:
i have a problem with the grafic. i cant see the lower part of the screen.
I dont know how to post a picture of the problem
My Notebook:

intel core i5
Intel HD grafic 520
8 GB RAM
anyone a solution of this Problem?

I inserted my AoE1 Gold Edition CD-ROM and installed it on Win 10 x64 build 1809. Then I installed the RoR UPatch.

So, why isn’t there such a patch for original AoE? I’d love to play through the original campaign again with the same things the patch does for RoR.

1 Like

Hi @KVUGNG, Age of Empires: The Rise of Rome Expansion includes the campaigns for both the expansion and the original release.

1 Like

I installed original AoE plus the AoK expansion then the UserPatch 1.1 R4 HD onto Windows 10 Pro X64. That works great and looks great.

So then I install AoE 2 + Conquerors from my old AoE Gold set, then the last update for Conquerors so the UserPatch for that will install. Works great, looks great, but unlike for AoE 1 the setup and menu screens haven’t been given the HD treatment.

Unfortunately installing AoE2 breaks AoE1! When I go to start the campaign it crashes. empires.exe the application has requested the runtime to terminate it in an unusual way.

Jumping into a random map works, but that’s it. I didn’t try playing an AoE1 campaign (hadn’t even saved a game) after installing AoE2 + expansion before installing the UserPatch for it so I don’t know if it’s AoE2 or its UserPatch that breaks AoE1.

Edit: Reinstalling AoE1 + expansion + last official patch + latest UserPatch does NOT make any difference. It passes the file check, passed it before.

i have all aoe on cd. I bought a pc without a cd player. the PC is windows 10. How do i register my cd keys with microsoft to get to play the game on line?

You can buy an external DVD drive to install and play your disc copies of the games on your new PC.

The Zone for online multiplayer was shut down many years ago for AoE and AoE II. As far as I know, you can still play AoE III on ESO using a disc copy. @EaglemutOP, please correct me if I’m wrong.

Unfortunately there is no way to redeem AoE CD keys for digital copies, like Blizzard does with Warcraft III.

1 Like