"Into China" - game crashing when getting the bombard cannons

Game Version:

  • Build: 101.101.35584.0 4714640 (I guess that’s the numbers you want? But just in case, I just downloaded the newest patch as of today before I started up the game)
  • Platform: Steam


I wanted to replay this map to finally get its achievment (even though I was eligible for it before, but I’m pretty sure it was bugged before), and wanted to use my usual strategy in defeating Yellow in time. This includes getting the bombard cannons as soon as I can to get them onto Yellow’s island and use them. Unfortunately, when my scout (or rather Light Cav) arrived at the spot where you get the BC, I heard the sound of them joining, but immediately after the game freezes and crashes.

Reproduction Steps:

  1. Play “Into China”, the third map in Gengis Khan campaign.
  2. Go to the place with the bombard cannons that the player can get - it’s behind the Great Wall, behind Red’s base (when going from the water, as I did it with a scout).
  3. Succesfully crash the game.

Since the game crashes, a screenshot is useless.


Game Version: 35584

  • Platform (Steam)


Crash upon following the steps below.

Reproduction Steps:

  1. Enter Genghis Khan Mission 3: Into China.
  2. Send any unit to find the bombard canons of Engineers inside Great Walls.

Thank you both for this report! We now have a ticket tracking the problem so we can work on a fix.


I also experienced this bug

Me too. Will try changing graphical settings to see if it makes any difference.

Edit: Still crashed on lowest graphics.

That achievement is still doable without the BCs. But you’ll have to set up your base north of the Jin (Yellow) island. And start booming with villagers to get to Imperial.

I also see reports of the achievement not popping beyond 50 minutes of play. Mine actually popped at 49:40 immediately after “Jin Defeated” notification. My previous successful attempt at 57 minutes also did not pop the achievement.

I don’t care if it’s doable without the BC. Maybe it’s not doable for me because I suck so much lol. I don’t really want to try and see. :smiley:

Besides. this thread is about reporting a bug I encountered while playing the map. It’s not about strategy.

The reason I’m recommending without BCs is because the Tanguts(Red) tribute a lot of resources to Jin(Yellow) the moment you find the BCs. The following line is from the “Into China” wiki page:

“Once the player obtains the Gaia ‘Engineers’, the Tanguts immediately tribute 10000 wood , 10000 food , 10000 gold , and 10000 stone to Jin.”

So Yellow immediately get resources to make the wonder. But if you manage it with the BCs before they start building, then go for it. :+1:t3:

Yeah, Red tributes a lot of resources to Yellow… so what? I did get the Bombard Cannons and defeated Jin before they even touched the Wonder, but the achievement was bugged at the time and wasn’t awarded. So that’s not an issue for me.

(I always thought they tributed the res after you get the vills in Blue’s base, but maybe I’m wrong)

Hi everybody. I’m playing AoE2 DE on steam, and the game crashes as soon as I find blue in the third part (into china) of Genghis Khan campaign. Any fixes or explanations as to what causes it ?

Anybody else with that issue ?

Hi @hrco991. This is a known issue.

Game Version:

  • Build: 35584
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: dkm72


If I explore the black area (to trigger the Engineer’s base above) the game crashes.
This is during Genghis Khan Campaign (mission 3 - Into China)

Reproduction Steps:

Explore the black area :slight_smile:

  1. Explore the black area :slight_smile:


Hi @dkm72, This is a known issue and is being tracked by the developers.

1 Like

Ooops, sorry - I didn’t see it listed already. I should have searched on the level name not campaign. Thanks!

Game Version:

  • Build: 101.101.35584.0 4714640
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: Tsongor


Ghengis Khan campaign mission 3 (Into China) crash problem

Reproduction Steps:

Here’s how to reproduce the problem:

  1. Play the Into China mission
  2. Reach the Engineers with Bombard Cannons
  3. Game crashes the moment you take control of the BBCs



Hi @StrangeImp73182. This is a known issue and is being tracked by the developers.

1 Like

Game Version: 101.101.35584.0 4714640

Northwestern siege engeneers game crash

Everytime I have tried to acquire the bombard cannons from the camp, the game crashes. When I tried to destroy the camp with trebs, the game also crashed.
No problems with the northeastern camp with villagers, battering ram and mangonel
When I’ve tried a new game it also crashed.