Invisible units


#1

Hi all,

I’m back again. Tried AOE definitive edition, been a few months since i last tried. I believe this was my previous post. Invisible Units

Tried the campaign, still invisible ships.

I was so hyped for AOE but unfortunately this invisible scout ship and the scout horse bug has made it unplayable.


#2

Did you try what @PCS70 suggested to resolve your issue?


#3

Aside from using a new account how would I fix an account issue? Would microsoft support be able to help that?


#4

PCS70 suggested creating a new Windows user account. You will still sign into Xbox Live using the same Microsoft Account.

There is nothing wrong with your Microsoft Account. Your Windows user account may be corrupt and creating a new user account will diagnose that condition.


#5

My computer knowledge is not good enough to fully understand that. Windows and microsoft accounts are different? does that mean I need to log into my pc itself from a different account? That would surely mean I lose everything my main account has installed?


#6

No you will not, unless you would delete that account. All installed programs will be available below that new user account. Later you can move your personal data from the old profile to the new one.

Yes, there are differences between local user accounts and Microsoft account connected user accounts. But this problem can appear at both types of user profiles.


#7

This does not seem to work. Or at least not 100%. I logged on to the microsoft store with a different email and played using the installed game and i was able to see the scouts and scout ships. Since then it has not worked.

I cannot figure out what is causing this problem across accounts and on multiple pc’s. Any thoughts?


#8

First of all. You can only play the game with the Microsoft account that has been used to purchase the game. You need to be signed in at MS store with that account and play the game using that account.

Secondly. The account used to sign in to Windows can be a local user account or the previous mentioned MS account used to purchase the game.

Sometimes the user profile you sign in with got damaged and there is no way to fix that for regular users except for creating a new fresh local user account or removing and adding their MS account on that computer after backup of data and cleaning the profile folder.

If this is to difficult for you to perform I would like to suggest that you try to fix your problem by getting help from a techie close by or try to perform an in place upgrade of your Windows 10 using the media creator tool available at the link below.

https://go.microsoft.com/fwlink/?LinkId=691209


#9

As far as I could test, I could play the game with other accounts that didn’t buy the game, if I log with it on Xbox App and then run the game, it starts and can play games and record data on its ageofempires.com stats account. I just needed to download the game with the purchase account then I could change the account running the game.


#10

Thank you for correcting me. I didn’t know this fact nor did I try it.


#11

In fact, I’m not sure it can 100% run it this way, I never made a long game on it.

I think this may be a cause of my crashes on the other topic :

Only my account is ‘purchaser’ of the game, none of the others. The ‘license’ thing in the logs made me think it could come from this. But, as the crashes are totally random (even on my purchaser account), I wanted to think it’s another cause. In my tests, it never crashed on a single computer, my main one which also played the beta, even if I log with a non buyer account on it.


#12

Very strange. Especially that you were able to play with an account that didn’t purchase it. Probably those license errors have to do with it. I’m sorry that you never got a answer to your question or at least a confirmation if it should work or not. This should be something to be easily answered here, as probably there are users who play LAN with multiple accounts.

This might be also an indicator that there are no problems with LAN games at all.

You might try to join a contest for a second AOE DE game key, so you can test this the normal way too.


#13

Well, as I didn’t see a specific error message about this, I wanted to think it’s ‘allowed’ to play several users with same license, as it was allowed on Age1 1997 and where the game was counting who had the CD and who hadn’t.