Is it normal for me to take forever to download one of my mods?

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: ######
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


I have just released a mod: Mods Single - Age of Empires, its a campaign puzzle scenario. After a few days, I started patching stuff. However, for me, both the initial download, and any updates take an extremely long time to complete. I’ve also found that my version isn’t updated to what it should be. Is it more likely that I messed something up (I did release another update while I was downloading the previous one), or that something broke? This is really annoying, because I don’t know if other people are experiencing this with my mod, and I released an update that patched a game breaking bug, but it hasn’t come through for me, and I’m desperately hoping that it has worked for others. Does anyone know why this might be?

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

This is the first time I’ve published a mod, and it only happens with my mods. I can download similar types of mods by other people within ten seconds, yet mine take hours.

  • 50% of the time / matches I play (FREQUENTLY)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. I’m not sure. If you could download my mod and tell me whether it takes forever for you to download that would be good start.
  2. Then, if someone could help me check it it’s up to date, that would also be really helpful. The best way to do this would be to load up the game and click on one of the trade workshops belonging to teal (player four). If it has been titled “Bazaar”, then my mod is up to date, its probably only an issue with my thing, and this becomes a lot less of a problem for me. If it is called “Trade Workshop”. then either I’ve done something wrong, or there is a bug with uploading.
  3. Other than that, I’m not sure.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

I’ve never done this before, but I would expect to download and update my mod within the usual ten seconds, and for it to be up to date after I released an actual update.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

It basically looks like this for most of all time. I think I selected it, it isn’t normally teal.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

Solved it. Because of the low quality instructions on publishing mods, and me not realizing that you can zip multiple files, I had accidentally been zipping one file too high, and messing stuff up.

1 Like