Issue with sacred sites (crafted map)

Since the latest update, the sacred sites look right again. They also work in a new mod (crafted). Still not in my mod (since the update with the new DLC). Before that, they worked wonderfully.

I also see a line, looks like a health bar, which normally doesn’t exist:

The sacred sites can neither be captured nor taken over.
Even sacred sites which I have tried to place later via script while the mission is running have this problem.
No idea what has changed with the DLC that can cause this effect.

It’s the only thing why I can’t publish my second mission. I hope for support.

Best regards
NTL

In case anyone is ever interested. Here are the steps to reproduce it:

  1. Place via editor a sacred site (holy_site) on the map
  2. Paint an interactivity area in the area of the sacred site
  3. Activate the interactivity area by script in your mod at the desired time

If the sacred site was placed in an interactive area that is activated later, the sacred site will no longer work. It will then look like my screenshot. This bug has only existed since the new DLC.