Lag since upgrade to Lords of the West

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 44834 (with Lords of the West)
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


Lag during online play. Prior to updating to Lords of the West it worked fine, now lags bad and sometimes will get server connection message.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS) - when I play online. Vs only AI is fine

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Play online game via ranked or lobby

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
No lag

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.
“Sorry, new users cannot upload attachments” :frowning:


Same for me. Appears only when playing Multiplayer, so i figured it doesn’t have to do aything with my setup. Before the Lord of the West DLC it worked perfect.

I removed the DLC and it worked like normal after that… seems like a workaround for now as far as I can tell :confused:

If I wanted to do the same, how do I remove the DLC? Isn’t it included in the newest game-update?

In my case I got the game on Steam. I had AOE2:DE before and then bought the Lords of the West DLC.

If you are also using steam you can go to the Games section under Library. It lists your games library on the left hand side. Then you can right click on AOE2:DE and Select Properties. From here go to the DLC option and uncheck Lords of the West. So then when you launch the game you wont get the 2 new civs or anything, but it seems to work for me.

Hope this helps