Launch failure

Just downloaded aoe2 and program will not launch, any suggestions?

Where did you download it? From steam?
Was it the HD version?
Whats your OS?
Does it say something when you try to launch it?

(sorry for my english i’m a french player)

Hello ! I’ve got a similar problem.
I bought the AOE2HD on steam and after the dowload, when i launch it i’ve got the launch screen with all the links and when i click on the play button a new screen is opening.
In that screen i’ve got a timer on the top screen and some things written like number of mods launched and other things.

And that’s all !!! The timer is working and no gmae’s running.

Someone can help me ?

1 Like

try renaming AoK HD.exe to Launcher.exe and Launcher.exe to something else

I had that problem too.
So i tried a few things and it worked again.
Follow the steps below:

  1. Right click the game in the library.
  2. Select properties.
  3. Click Select Launch Optionsin the new window that pops up input -nostartup.
  4. Click Ok.
  5. Start up the game.

I already try this and still don´t work, I buy it From Steam and it don´t Work

1 Like