Launch issues AoE2DE

Installed AoE2DE via the MS Store on my MacBook Pro 13 (2018 version) using bootcamp and the Nov 2019 edition of Windows 10 Pro.
From the start, everything was running perfectly using max settings (excl. UHD pack) for several days. Unfortunately, when I tried playing yesterday, the game didn´t launch. No errors whatsoever, but when I clicked on the launch icon or ´play´ (via the MS store), nothing happened.
Reinstalled the game yesterday evening and everything did run fine again. Today, same issue…

What´s going on? Please help!

Welcome here on the forum. Let’s see if we can find out what’s going on here.

How much internal memory has your MacBook Pro and how much free space is still remaining on the C: (system) drive of your Windows installation?

Many thanks for your feedback. 8GB of ram and 15GB of free space on my Bootcamp petition. Just noticed there was a patch, and now everything is running again. Strange.

1 Like

Also try to up your free space to around 20-24 GB at least. Search for disk cleanup. You could also remove certain components from windows to lighten it’s footprint further.

Unfortunately, I only have Win10 and AoE2DE installed. Also, I always tend to clean up my disk and temp files. To gain more space, I will have to increase my Bootcamp partition, and that’s not possible, as far as I am aware. :frowning:

If you don’t use the Windows a lot except for AOE it should not be too difficult to reinstall it again on increased size fresh boot camp partition. And you don’t have to buy Windows again. But if you lack enough free space on your MacOS disk in general it’s cumbersome indeed.

Had the same problem yesterday. Both it and AoE:DE seemed to forget they were even installed, and Settings -> Apps would crash when I tried to select them to uninstall. Again they had been running peachily for days before.

When I finally convinced them to uninstall, and then reinstalled 2, it worked, but it gave a UAC dialog first about Package Dependency Installer, which I had never seen before, and it seems that that was the underlying problem, and this is not the first time. I think there was something janky going on with Xbox services yesterday.

Hopefully we don’t have to keep reinstalling these large games regularly for such things. It is crazy that we have come to the point where re-downloading 20+GB is not that big a deal, but we still really shouldn’t need to.

1 Like

Good to hear that they added a package dependency installer.

Today, the issue re-occurred. Unable to launch the game. 16GB of free space should be PLENTY enough, as I don´t even have the UHD pack installed.
When I hit ´play´ nothing is happening. I also disabled UAC. No luck…

Any fix? I can´t reinstall the game every day…

Please note, I went to “App settings” and clicked “Repair”. Took 2 minutes, but when the “repair” was over, the game launched itself. There really seems to be an issue with the game or Win Store launcher.

It’s strange the repair option took 2 minutes, that usually takes very short time.

16 GB of free space is not plenty enough but maybe there is a delay of 2 minutes between launching and the moment it finally starts?

Next time before starting launch the task manager (Apple key - R -> taskmgr) and then launch AOE II DE. Check if you see the application running and just wait a while (like 2 minutes) and see what happens.

If there is a delay, then it’s around 7-8 minutes. This is how long I waited till I hit the “repair” button. This might however have been the case. When the game didn’t launch, I tried again. When the game finally launched, after the repair was done, it tried to launch 2 instances, which triggered an error about running multiple instances (even though, in the end, the game did launch). :frowning:

So there’s definitely something slowing it down in your case. You can check with task manager and from the performance tab open resource manager to check what’s going on.

Stuffed again. Game runs fine. Finish session and exit game. Game will not launch.

MS Store 33164. Didn’t happen before that version. You can see the problem immediately if you launch from the Start menu, it doesn’t even register the click, and Settings --> System --> Storage --> Apps denies the game is even installed, while System --> Apps crashes when I try to repair it.

And now out of town for a few days on hotel wifi so can’t really download again lol. What a mess.

Edit: Oh and this time it is without UHD installed, so that doesn’t affect it. Hopefully another update is forthcoming soon! And this, with 55/236GB free on SSD.

Okay this may be a clue. The game is not exiting correctly, for one thing. And THIS was after a fresh restart and trying to launch once, then waiting several minutes:

And then it decided to run anyway. So at least there’s that lol.

Just tried again. Clicked “Play”, however, nothing happens. Opened the task manager, and seeing 3% CPU usage, 31% memory usage and 1% Disk usage.

So, for 5-6 minutes nothing happened, hence I, once again, hit the “Repair” button. Took 3 minutes and, guess what, the game launched.

It did display an error however: “Fatal error File error 12”.

I have also seen the error pointed out by mvon007 before.

No clue what’s going on, however Microsoft should fix this ASAP!

Strange things going on with boot camp users. Keep adding your findings. You should be able to see the AOE II DE process with task manager when you expand the view using the arrow button in the bottom bar.