List of unfixed bugs

KDA related problem (in fact 50 kills scores +/-160 kills in the end game stats)

I played an arena game as byzantin and while watching the replay i realise that my KDA was 3 times bigger or something close to that.

Everytime one of mine cataphract kills one enemy’s tarkan my KDA score 3-4 kills.

Note: I had logistics when the bug happened. And every other upgrade for the cataphract.

Hmm can you send a rec? I am interested in reproducing it myself

Also do make a separate report for this if u can, so the devs can see

edit: i just tried to reproduce it with both unupgraded catas and also logistica ones, seemed to work fine, tho it wasnt really a massive battle.

I am a new user here and cant upload the replay.
Sorry about that, but I can sent u the link of the replay in
My nickname: “vilela do mato”
It is the last game in my profile. “Arena 4v4”

download the replay in this website and it should appear in the recorded games (make sure to put the file in the right place)

Not fixed in this patch!
Plz just care about campaign players

Not sure how to make a new post for this, so I’ll report a bug here. The “as numerous as the sands of the sea” achievement isn’t triggering for me. I played through once before I knew about the achievement (and thus made non-infantry units) and twice since making only infantry. After it not triggering the first time (making only pikemen and huscarls) I tried just making only huscarls in my next attempt but it still didn’t trigger.

Is there a chance to fix this bug? Have same problem with game installed through Xbox app on Windows 11.

Seems that achievement Can I be Frank with You doesn’t work.

Not sure if I’m doing this right, I signed up just to report this issue with the Gurjaras. It does not allow the elite Shrivashma unit to be upgraded.
If I start in post imperial, it’s there. But on XBox, it does NOT allow me to upgrade that unit. Kinda killing the use of the Civ I paid for on the DLC.

I recently encountered a problem with one of the new Inda Campaigns (Dravidians)
The first maps morale function is bugged. Supposed to add damage to units when using heroes. Mine makes all of their damage 1. Light cavalry reads 7-6 and the heroes are 19-18 and 15-14 after the first damage upgrade and stay that way into further upgrades.
Please redirect me to where to actually post bugs if this isn’t it.

This isn’t quite where to post it, normally people make a new thread for bugs they want to report. I wouldn’t bother though if I were you, the devs are well aware of this issue by now, it’s breaking any use of the modify attribute trigger, where instead of adding values, it’s setting them. In this scenario for example, it’s meant to add +1 attack. Instead, it’s setting the attack to 1 for everything, hence the attack values.

Yeah, this has been reported on this forum several times: here and here and here among many others; it’s also been noted on the Steam forums.

You know, I really wouldn’t mind having an update on if it’s going to be sorted soon, since it’s really cramping my playthrough; I check for a new patch almost daily.

Is anyone else having the issue listed with the Gurjaras? I’ve uninstalled and reinstalled a few times now.

im curious, whens the last time the dev look at this pinned thread?

1 Like

this list got nothing to do with devs, and tbh I am not even sure why they decided to have it pinned.

Can I get a yay for this not being fixed still?


What’s the point in having an official forum with a bug list if the devs ignore it?

They spend time changing the civs around, making more bugs, and still dont fix all the previous bugs, its a joke.

This latest update, If you ring the bell quick (as I always have) to force drop off, it literally idles your whole eco, its basically GG if you ring the bell, especially if you ring it to click imp…

1 Like

Big Problem with [Age of Empires II: Definitive Edition - Update 81058]

Since the new Update 81058 was installed automatically by Steam the KI-Mode for original “CD-Version” isn’t working properly anymore.

When a KI-CD-Version-Opponent changes his diplomatical status to you the game freezes nearly everytime and cannot be restored properly.

As well, sometimes working menus of citizens start to switch automatically, so that you cannot build new buildings anymore because menus are jumping by themselves. (This is just happening sometimes, the diplomatic issue appears everytime)

I’m one of the early AOE-Fans since 1997 (Part I) and I always loved to play against CD-Version-KI. Now the game is not working as I want it to anymore.

Can I remove the 81058-Update somehow … ?

1 Like

yeah, my campaigns have just been crashing all together after a few minutes of gameplay, bout to ask for a refund

On the PC version, ungarrisoned villagers have been having some strange behaviors recently. A shepherd might just kill another herdable when you garrison and ungarrison them for faster food income. A hunter will be idle for a few seconds before shooting if you garrison them after bringing the boar next to your TC. A builder will not build a building if they stand on the foundation instead of just walking away before building.

There might be more, but these are the most common strange behaviors I’ve observed. I believe it’s some kind of bug and not “intended” feature.

1 Like

Add this bug to the list please so it gets the devs attention:
User Interface, Lobby, Spectated Games:

Banned maps do not appear in team game

This is the most visible bug for anyone who plays ranked team games and it happens 100% of the time. It hasn’t been fixed for almost 2 years now.

Other problems and bugs:

  • Rematch button is useless because it waits for too long until all players vote yes and sometimes it doesn’t work properly even if all players vote yes. Instead change it so that it creates a new lobby and when a player click on rematch he joins it immediately.
  • Changing Hide civ option in lobby options without the need to recreate a new lobby.

Hotkey suggestions:

  • Add hotkey/Button to make spawned units spawn garrisoned inside their spawning building.