Matchmaking search failed: Service is not available/Request was invalid

Game Version:

Version 101.101.32875.0 4392666
On Steam


Whenever I try to Find a Match in match making I get the message : “Matchmaking search failed: Service is not available” and “Matchmaking search failed: Request was invalid”. Sometimes it takes a while and I get to wait in queue for a few minutes but usually its instant after I press the “Find Match” button. The first time I did managed to play in matchmaking but crashed after a few minutes in the game and now I can never seem to start a Matchmaking search again because of this error. Some times I even get stuck on the “Creating Party” loading screen after pressing the “Find Match” button.

I’ve tried enabling cross- network play and disabling it as well as making sure the game is not blocked by any antivirus or windows firewall. Still the same problem.

Reproduction Steps:

By starting a matchmaking search it keeps popping up.



Same problem here. All the streamers I’m watching are facing the same issue as well.