Menus not being displayed properly while using Intel Arc A770 GPU

  • GAME BUILD #: 83607 (I think; I’m at work so I don’t have access to my game right now, but I’m on the latest version as of today, 5/22/23)

  • GAME PLATFORM: Microsoft Store

  • OPERATING SYSTEM: Windows 10

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

So recently I installed AOE2 DE on 2 new machines for my 2 kids. Both machines are running Windows 10 on i7-13700K and Intel’s new Arc A770 8GB GPU.

Both machines have a problem displaying the menu texts for AOE2 DE. The menus are there and if you hover over each item, you can see the descriptions on the bottom right of the screen. But the menu texts themselves are cut off in the middle, making them impossible to read. This is the only problem I see, because otherwise the game plays just fine.

By the way, I have 3 machines at home running AOE2 DE. These 2 machines (using Intel A770 GPU) and another machine (Nvidia GPU) that I’ve been using, and this problem occurs only on the 2 machines using the Intel GPU. In fact, when I unplug the Intel GPU on those machines, and plug the monitors straight to the motherboard’s integrated GPU, the menus display just fine.

Therefore, this bug appears to be a conflict between AOE2 DE and the Intel Arc GPU or driver.

:arrow_forward: EXPECTED RESULT

Obviously I was expecting the normal menu texts, which everyone here should know.

:arrow_forward: IMAGE

I’m not home right now so I can’t do an actual screen ##### but I found another website (Intel) where someone describes the identical problem, so I just grabbed their image. The game version is obviously different, but the problem is identical. Let’s see if it uploads!


Did you try different drivers?
Thanks for your report.

It’s a new machine so I only have access to the latest driver that Intel has (version

But it’s clearly something to do with the GPU/driver because the menus display fine when I use the motherboard’s integrated GPU.

Yes, it must be a problem with that driver, there must be a way to find and install an older version :slight_smile:

When I first had this issue, I googled and had found this exact same problem posted on Intel’s community page. That user was using older versions of the driver, and the problem persisted. (See below link).

The weird thing though, is that the Intel folks tested it and claim the game worked fine and even posted videos of it. I have no clue what the videos showed, because the links are dead by the time I discovered the post. Although that original user marked the case “solved”, it doesn’t sound like he ever got it fixed.

So assuming that there is an incompatibility between the game and the GPU driver re: that text size, who should be fixing it? (Although I know that most likely, no one cares and this will probably never be fixed).

Can you try downgrading to driver 4091?

Intel® Arc™ & Iris® Xe Graphics - WHQL - Windows*

You can select 4091 on the dropdown menu. if it works, then you should contact Intel support telling them that there’s a regression with this again in 4369 :slight_smile: