[MERGED] Late-game performance in team games deteriorated in anniversary patch (42848)

Haha, look how TGs look like. ALL players are red and lag as hell, its unplayable atm…

4 Likes

The same is happening to me in games against the AI, in 4V4 when it reaches post-imperial the game stutters a lot and it is very stressful, it had never happened to me

2 Likes

for the love of god THANK YOU for being on top of this, this is really killing our enthusiasm to play the game currently. hope we see a fix soon.

1 Like

I know we are talking here about Team Games but I played two 1v1’s yesterday and my opponents told me this was unplayable to them. I guess they’re not lying because I’ve never had an opponent complain about lag in 1v1 before the Anniversary Patch.
Not sure if I can do a thread myself to report the issue since I have no actual proof of it happening.

Also more on the subject : meta will be Siege Onagers with Arbs until they fix it lol

2 Likes

Thanks. I think it maybe related to multiplayer only, I played a few skirmish games on single player and haven’t experienced any lag.

1 Like

:arrow_forward: GAME INFORMATION

  • BUILD #: 42848
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:question: DESCRIBE THE ISSUE IN DETAIL (below). Limit to ONE issue per thread.

In team games (4v4) the game consistently lags right after imperial. Almost everyone’s clocks become red. This is happening in every game, consistently, so it is not a matter of happening by chance. Something in the patch has caused this issue.

:arrow_forward: FREQUENCY OF ISSUE

:question: How often does the issue occur? CHOSE ONE; DELETE THE REST.

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:question: List the DETAILED STEPS we can take to reproduce the issue… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Play a 4v4 team game.
  2. Advance to imperial.
  3. Witness extreme lag in the late game.

:arrow_forward: GAME FILES

:question: Include a OneDrive or Google Drive link to a SAVE GAME or REPLAY FILE (.aoe2record) of the match where you encountered the issue.

:arrow_forward: IMAGE & ATTACHMENTS

:question: Attach a relevant PICTURE (.jpg, .png, .gif), VIDEO (.mp4, YouTube), DXDIAG FILE (.txt), or CRASH/GAME LOGS (.aoe2record, .txt) below.

16 Likes

I can confirm this issue happening to me as well. I used to play with my friends before the patch and had no issues in imperial age. But in this patch, the game lags like crazy as almost everyone had a red clock near their name.

6 Likes

This is a duplicate of Late-game performance in team games not improved in anniversary patch. It is under investigation by the dev team.

1 Like

It is not a duplicate because the title of that thread is incorrect. The issue is not that late-game performance wasn’t improved, it is that late-game performance significantly deteriorated after the patch.

3 Likes

Ok, but that doesn’t matter for the outcome. The devs are investigating it.

depends… if thread says not improved, they may choose to let it stay as is or simply revert to what it was before, which is still crap.

since they wanted to “improve” on performance, by stating that its gotten worse, they’d do more work to make sure it is not only fixed but “improved” vs pre patch.

big corporation will try to get away with w/e they can and not fix thing, always make details clear so they know what we want.

2 Likes

Don’t worry, I changed the title already. I still don’t think the title makes any difference for the outcome, but we’ll see.

2 Likes

Just confirming that I experience that as well - 4v4 games become unplayable as the game goes on : l - didn’t use to be the case before the patch

4 Likes

even 3v3, or 4v2 against 2 AI is starting to become unplayable… this is becoming really difficult to enjoy late game with the lag.

2 Likes

In just a 2vs2 the game got totally chopped, unplayable. FPS were 60 according to the indicator but they really felt like 200

1 Like

Hotfix 43210 is now available with a fix for this issue. Please give it a download and let us know if you continue to see problems:

3 Likes

Jordan played a 4v4 team game again today (with almost the same people) and the game ran much smoother! No more red clocks, even after 50 minutes game time with almost full pop.

I mark the issue as resolved. Thanks a lot.

5 Likes

it didn’t fix lag for me and get worse. now fps is 2-3 fps on late game !!! don’t fix which not broken , devs

3 human vs 3 AI today on Fortress, when we were 100 pop each game went ~5 fps (steam showed 45 fps, but game felt as 5 fps)

@TroubledCow83 and @bgolymp

share more information, otherwise with most say its fixed your concern is only likely going to get dismissed.

what servers were you playing on, how do you know its not the people you play with with poor computer specs