Miner losing gold when attacking boar

:arrow_forward: GAME INFORMATION

  • **BUILD #:**current
  • PLATFORM: Steam / Microsoft Store
  • OS: Windows 10 / Windows 7 / Mac / Linux

:arrow_forward: ISSUE EXPERIENCED

:question: DESCRIBE THE ISSUE IN DETAIL (below). Limit to ONE issue per thread.
I send a villager to gold. Once he collected 10 gold I send him to attack the nearby boar. He lost all gold immediately when becoming a hunter, before even attacking. Boar still alive.

:arrow_forward: FREQUENCY OF ISSUE

:question: How often does the issue occur? CHOSE ONE; DELETE THE REST.
Unsure, I tested in a single player game and it did not happen

:arrow_forward: REPRODUCTION STEPS


:arrow_forward: GAME FILES

MP Replay v101.101.41855.0 @2020.11.09 114558 (1).aoe2record (1.4 MB)
Minute 4.

You dont lose the gold while attacking the boar the gold is just not shown on your display. You lose it right away when the vills stands on the hunted dead boar and starts collecting food.

So, you can bring the boar to your TC, kill it with other vills and without starting to collect food you send the vill back to mining gold and the amount of collected gold before is back in the display.

Watch the replay, I did lose the boar the moment the villager started luring it. Boar was still alive, no other resource was gathered, or even clicked.
Actually I rewatched it and he lost the gold the moment he became a hunter, before he even attacked.

I dont have to watch the rec, I know whats going on. Did you even read my answer in total? :smiley:

I already explained it above: If you send the vill back on gold, the villager will get the before collected gold “back”. Its just hidden in the display while you tasked him on another ressource and not lost.

Sorry did misunderstand you then.
Its more than “just hidden” though. The villager does not carry the gold anymore.
I did garrison him in the tc and did not receive the gold. I cant test if he would have recovered it if I had clicked back on the gold after the match now.
Also it still is a bug, since regular behavior (as tested again in single player after the match) is, that the ressource is still shown.

Ok you are right, your vill lost all the ressources. I tried to reproduce it but in all my tests it worked