Missing campaign progression after the patch

Game Version:

  • Build: 101.11.37650.0 5061880
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: Sceletonx


My campaign progression is completly reset after after logging in today after the patch

Reproduction Steps:

I just patched, launched the game and progression is not there.
I still have my steam achievments but ingame progression is lost.
I tried relogging xbox live account



1st screen my ingame campaign screen for barbarossa, 2nd screen of my steam account achievments where I have the campaign completed

I have remembered one thing that may help! Earlier this week I had wierd freezes during one of my multiplayer games, so as one of the tries to fix it I have “checked integrity of game files” on steam. After that the freezes were gone and it is ture that after that I have only played multiplayer so it is possible that it has been reseted by that, and not by current update.

I have tried to reproduce it. I have completed the “early economy” art of war today to get thet event reward, got it. Turned off the game, run the verify integrity… and logged back… and indeed progress was gone for that mission also!

So it seems that updates or reinstallations etc. are resetting that and there is some issue with synchronization. I have steam cloud sync on and I am also connected to xbox live (tried with even with disconneting from there, didnt help)

I believe this happened before with some other update. :confused:

Weird question, but let’s see what we can learn:

  • Is your game installed to a “temporary” folder that gets erased whenever the application closes?
  • Do you have adequate hard drive space on your computer?
  • Would you mind verifying that your Steam settings are set to support Cloud Sync for us (a picture would be helpful).

I’ll ask the team what sort of information they need to investigate, but I’d love to know more about what might be causing this issue since it doesn’t seem to be universal or notably widespread.

Thanks for the report!

1 Like


here is additional information:

  1. screen of enabled steam sync
  2. screen of my drive space
  3. AoE2 is installed in D: drive (a think save folder is on system drive C: in user folder though, but there is enough space too as you can see in previous screenshot.)

Also I have completly forgotted and could possibly be the cause of this. During the last weekend I have needed to temporarly switch my game version to the older patch because I am one of the co-casters of Battle of Africa 2 for czech stream. (And then switched version to live to play anything of course, only thing I was doing on old patch was running replays). I just remembered that as I am just preparing older the version again for tomorrow cast. I am not sure if I have checked the progression between patching back to “april patch” on sunday and “may patch”. Last few days I was only playing multiplayer. So it could have disappear last weekend.

Thanks for looking into this issue, appretiate it!

1 Like

This is incredibly helpful! I’ve passed the information along to the team and will let you know if they need anything else to dig into the issue! :+1:

1 Like

Any update on this? I’m getting this issue in game installed from MS store.

I have read in patch notes that this issue is most likely fixed. Is there any way to restore my lost progression?

Sadly, no. It sounds like those of us who swapped branches at any point will, unfortunately, have to re-complete the campaigns or Art of War missions we lost. The fix, at least, will ensure that progress is maintained moving forward.