Monks dont recharge thier faith while carring a relic

:arrow_forward: GAME INFORMATION

  • **BUILD #: 101.101.43210.0 5867313
  • PLATFORM: Steam AND Microsoft Store
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Monks do not recharge their faith while they carry a relic. (or is that intentional?)

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)
    I tried different civs; Huns, Persians, Mongols, Aztecs and I tried it in dark age and post-imp

:arrow_forward: REPRODUCTION STEPS

:question: List the DETAILED STEPS we can take to reproduce the issue… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Convert a unit with a Monk
  2. pick up a relic (while having less than 100% faith)
  3. see that the faith (bar) does not recharge, when the monk carries the relic
  4. when the relic is dropped, faith regen is normal

:arrow_forward: IMAGE & ATTACHMENTS Monk carry Bug 1 Monk carry Bug 2 Monk carry Bug 3 Monk carry Bug 4 Monk carry Bug 5

Special note: Thanks for the faith bar I saw it in-game, I am sure I had the issue before but it made it really easy to show and realize.

1 Like

Monk and Monk with relic are different units.
Monk with relic cannot regenerate the faith. A monk with 100% faith drops his relic even loses all faith to 0%

1(Yes) a monk and a monk with relic are different units(in editor)
2(No) a monk with 100% faith does not lose his faith when he drops a relic
1(yes) a monk with relic(in editor) does not spawn with faith, and that’s why he has no faith when he drops the relic. (which could be considered as a bug as well, but I would say it does not matter)

I realized that bug, while i played a ranked. My monk carried a relic, i dropped the relic to convert an enemy unit, picked up the relic again and saw the faith does not regen.

After further testing Monks with relics recharge faith, but way slower than a regular monk. Maybe 1/100 of the regen rate.

Still not sure if it is a bug or a feature.

I noticed this as well, playing a campaign mission. Wasn’t sure if it was a bug or the intent though.

1 Like