Montezuma 5th campaign - obtained units change corpses

Game Version:

  • Build 101.101.34793.0 4597979
  • Platform Steam


In the 5th Montezuma Campaign a player can obtain horse riders and bombard cannons. However, when these units are killed after a second they corpse change graphic nto the corpse of “previous” unit.

Horse riders -> Horse
Bombard cannon -> Trade cart

I assume this would be a general issue and is not linked to the particular mission.


Hey there! Very interesting issue! A few questions to learn a little more about it:

  • Does this issue only happen on this particular mission? Have you managed to see it elsewhere?
  • Have you tried verifying the integrity of your game files to see if that fixes the issue?
  • Are you able to capture a short video or gif of the bug in action?

Let me know what you know, and thank you for the report!

Thank you for your reply!

I will do more tests and will let you know. However, now I am a little bit busy but I believe on Wednesday I will have plenty of time to report more :slight_smile:

I have found free time :slight_smile:

  • No, I have not seen that. I tried to simulate it in an editor and it works as it should.
  • I tried it before any tests I performed today and no change.
  • I hope it is sufficient:

Excellent! Thank you! One last question, for clarity:

  • Are you running the Enhanced Graphics Pack or any other visual mod? If so, does the issue still happen when they are disabled?

I have no mods and when I disable the EGP the issue still prevails.

1 Like

EXCELLENT! Thank you for that last detal; I’ve included it in the report to the team.

Thanks agian for the report! :slight_smile:

1 Like

I thank you for the care!

1 Like

Today I replayed the mission and everything was alright. It seems the issue was repaired. Thank you!

1 Like