Multiplayer freezes then fast forwards to be synchronous again

I have this same kind of error in my system. I have a high-end gaming pc and a high-end gaming laptop. I’ve noticed it happens most consistently on my gaming PC which has an AMD RX 6800. I have tried just about everything I can think of. It mostly occurs if I am playing online with multiple friends and we have 3-4 AI players on Hardest or Extreme. Has anyone had any luck with resolving this issue? As you get futher in the game the lag gets worse. Very frustrating.

1 Like

I have this error as well. Decent gaming PC. AMD 5800X, AMD 6700XT, and 16GB of RAM. It will start micro stutters a couple minutes into a game. Then as time goes on the stutters turn into freezing until it becomes unplayable. When playing multiplayer the commands I use are lagged behind everyone else playing and I won’t see them complete the commands for minutes. It has got to the point they finished the game and killed the last AI, 15 minutes later my game finally said we had won. We were sitting in the same room. I have metrics overlay on in Radeon. When it is lagging my GPU utilization drops to 0. When it is running fine I hit maybe 13-27% utilization.


I bought the two DLCs (Lords of the West, Dawn of the Dukes) yesterday, after which I started experiencing similar freezing (and subsequent fast forwarding). However, I also experienced it in the campaigns (Joan of Arc, second mission). So I’m not sure if it’s a network problem?

It’s weird, because before I bought the DLCs I did not have those freezes at all (or if I have, at most rarely). Now, almost every game, campaign or multiplayer with same mods installed, I have them very frequently and as the game progresses it gets worse. It hasn’t gotten to the point where it continuously freezes and fast forwards, I’d say the worst I’ve had is around every 1-2 minutes.

I tried reinstalling the DLCs only on Steam (by unticking and ticking the DLCs), and then a complete reinstall of the game (by uninstalling and then installing the entire game). Because I started experiencing them only after buying the DLCs, I don’t think it’s either a mod, network, or hardware problem, but if needed, my computer specs are i5-6600 @ 3.30GHz, 16GB RAM, NVidia GeForce GTX 970. T

he drivers should also be up to date, and I also tried to update my mods, but because I had no problems with them before, I’m not sure if they are at fault (playing on non-DLC civs also freeze right now).

Hopefully anyone can help, or maybe this was of help!

A friend (who funnily enough doesn’t play the game) advised to set Age of Empires folders as exceptions for my antiviruses, which I did (for Avast and MalwareBytes), and the freezing stopped for me. Not sure why installing DLCs caused a change - or maybe it was just coincidental -, but at least it’s fixed for me.

Not entirely sure if the problem was the same as others, but might be worth a try!

SOLVED : I have had a similar situation with the game freezing 3 or 5 seconds and then speeding up , and for me it is solved as of this moment …

this is what i did -
in your antivirus ( mine was Avira ) there was game mode activated … deactivate it and that’s it there could be a game mode in your motherboard software or any optimising software you have ( deactivate them all ) , i understand a lot of antiviruses have the same thing or some equivalent. It’s a simple fix but took me a while to figure it out because I came to the solution through elimination i had previously changed monitors, graphics cards AMD 6800 and Nvidiartx 3090, v-sync reinstalled windows everything. but nothing worked
I hope you guys get back to playing I had stopped for more than 6 months due to this and am glad I can finally play again

1 Like