Multiplayer game becomes unplayable (rubber-banding, input latency, etc)

It’s nice to know I am not the only person that shares these frustrations. The game is extremely clunky and it doens’t matter if you have a $2000 or $10000 PC, the game will likely not run well.

The ranked test gives me 1370 and runs smoothly. Playing online = I get these freezes.

Microing is near impossible when this happens.

My other friends dont’ get the issue so they don’t know why it’s happening for me…

I guess no mods or developers are on this forum are they?


They tend to read, but dont really actively posts.

Well, what a waste of money they are. No action towards fixing the lag issues with the game. My game went down to 5 fps today and lagged immensely It’s unplayable. WHAT CAN I DO? It’s unplayable.
I literally bought this new PC hoping it would fix the issues I had on the last computer, and they are the same. I am so sick of this game. So sick of it.

Hi , i dont know it there is the place to ask that buy anyway . I cant run the game becouse it crash at second whit the error “ATL RADERON HD 4300/4500 SERIES GPU whit vendor id 4098 and device ID 38223 is not DirectX 11 compilant”. If someone can help me o tell me where i can ask about ,i really need it.

PD: Sorry for my english

Since Hotfix, After joining, the game freezes for me at 8-12 mins, or other players disconnected in this time

There are 3 issues -

  1. Either me, or another player is stuck at the loading screen forever
  2. After joining, the game freezes for me at 8-12 mins, or other players disconnected in this timeframe
  3. I cannot join the game at all

These three started happening after the hotfix

The issue noted in OP sounds a lot like this issue that has lingered a long while:

Someone in a different thread mentioned they fixed it by resetting (their) router. So new IP etc.. That sounds like a band-aid workaround that may work for a few players, but I feel the game has some deeper issue somewhere that needs fixing by devs since so many people have this issue.

HI, yes I have reset my router several times. I have not seen any devs on this forum… Quite disappointing the level of support. To be honest I don’t think Microsoft are behind this game I think they gave it out to a small 3rd party firm.

Hello all,

I am playing on the latest build.

Today when trying to play multiplayer matches I have had continous freezes starting from the very beginning of the games that last up to 2-3 seconds. After which the game will quickly “catch up” and speed up everything that happened to be in sync again. However it will happen again quickly after and so on.

I have stable internet, a monster of a PC and never had these issues before. I have over 100 hours in AOE2:DE and never had this issue. What could possibly cause this?

My mate who is with me in the same game does not have this problem. He tells me my connection symbol is constantly Blue so there shouldn’t be any issues. In Singleplayer I do not have this issue. I verified integrity of my game files as well. The problem appears in regular ranked matchmaking. Wether 2v2, 3v3 or 4v4 doesn’t seem to matter, the problem exists in all these cases.

My commands are registered and I see them being carried out after the delay is over (and in sped up fashion because of the freeze), but they do not “get lost”.

1 Like

thought maybe the server problem ,i got this issue too after the last path

I have the same issue


As you can see no one even bothered to respond to your post

I have the same issue. clearly I am not the only one.

Microsoft is absolutely dropping the ball here. Why are they IGNORING their customers? Scam?

I fixed it by resetting my router. So new IP etc… Not sure if that works for you.

1 Like

Doesn’t seem to make a difference for my router, I even turned on QOS. Game is extremely laggy.

I have the exact same problem where the games freezes and catches up since the last patch, I can scroll around the map but not do any actions. :neutral_face:

Sounds a lot like this bug reported a while back:

Hi guys,

Been trying to rack my brain over this one and I’ve come up empty. Any support would be appreciated.

Firstly I want to preface that my graphics card runs single player perfectly fine with Ultra graphics enabled and max resolution. However, as soon as I enter a multiplayer game, my game stutters beyond belief. It doesn’t really feel like an FPS thing as the graphics card seems to cope fine between the stuttering. Sometimes it takes ages for for any input to engage - e.g. I will Q to queue a village and it will take the game 5 seconds to actually start the queue time. This stuttering usually gets worse until the game seems to “de-sync” from everyone else and and then will just freeze, forcing me to resign or quit the game.

I feel awful because the only way I can test if any change I make actually works is by joining a public match with out people. Please can someone help me out. My ping is fair for the most part paired with my local server and I pass the benchmark test always over 1150 or so.

Thanks so much in advance!

1 Like

Game Version:

  • Build: replaceme
  • Platform: Steam or Microsoft Store
  • Operating System: Windows 10 or Windows 7 or Mac or Linux
  • Gamertag: replaceme


Was clicking on villagers to build or go somewhere, It would take at least 30 seconds before they would do what i wanted them to do.

Reproduction Steps:

Here’s how to reproduce the problem:

  1. (List the steps we can take to reproduce the bug ourselves…)



1 Like

If you’re on Steam, verify integrity of game files, and restart your PC.

This bug’s probably happening due to your game files being corrupted or damaged. Or because there’s something wrong with your PC.

A friend and I are having the exact same problem. It happens later in the game. We are playing in a private lobby. We’ve both verified our files and neither showed any issues. There are no PC issues with either computer. I’ve recently run memtest over night with 0 errors and haven’t had a single issue. This happens almost every game we have to one or the other of us. Neither of us have any mods installed.
@SlenderBadger98 any other suggestions?

1 Like

Not really. I wish I could do something other than keep encouraging you to post updates on the topic if that’s the case. Thanks for your own experience. If more than one person has the issue, then it’s probably something wrong with the game and not the PCs they are run on.

Units not following your command is a game age bug. If you read the patch notes for the age of kings, there is written this

Microsoft Age of Empires II: The Age of Kings2.0a Readme File
August 2000
Unit Ignoring Orders Bug - Units no longer ignore orders under some circumstances.

Still not properly fixed.

Also there is this note

Limited Pauses - The total number of pauses available to each player in a multiplayer game is now limited. The total number of pauses remaining is displayed each time the game is paused.

Is this still the case?? You definitely don’t see a total number of pauses.

1 Like