Multiplayer game freezes and later speeds up to catch up

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • **GAME BUILD 8647032
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

When playing a multiplayer game, the game freezes for about 5 seconds.
After those 5 seconds the game resumes but speeds up to compensate for the 5 second freeze.
During the freeze the game keeps going on as usual for the other players.
The freeze happens once every 2 minutes.
Lowering resolution or graphics does not resolve the issue.
My internet speed test detects no problems.
I had this problem once before but an update resolved it.
Now the problem returns since the latest update.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Play a multiplayer game. Amount of players or npc’s is irrelevant.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
The game would run normaly.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.
I can not do this step since the issue is not detecable on a picture.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

Hi @TheNeowulf !

  1. Can you try to verify your files in the Steam Library? Age of Empires II → Right button → Properties → Local files
  2. Can you try to disable your mods? And restart the game after that.
  3. Can you upgrade your graphic drivers and check Windows update?
  4. Can you check if checking or unchecking the V-Sync checkbox in the Options improves your performance? Modifying the FPS Limit and making it closer to your monitor could help too.
  5. Can you try to close as many programs as possible before starting the game?
  6. Is your game in the last version?
  7. Are you connected to Microsoft Live?
  8. Can you disable Enhanced Graphics?
  9. Can you try to add the whole game folder to your antivirus’ exception list? C:\Program Files (x86)\Steam\steamapps\common\AoE2DE is the default, AoE2DE_s.exe is there.

Thanks! :slight_smile:

I’m having the same problem, but I’m not on Steam.

Tried to disable mods, V-Sync, Enanched graphics and run the game without other programs.

I had this issue in the past, then an updated fixed it, but after the last patch I’m having it again

Hi @Albeman3246
Do you have a good internet connection? Are you using wifi or cable?

Hi, I’m using wi-fi, the connection works great for everything else

If you have the opportunity, try playing a multiplayer game connected directly to the router with an ethernet cable, just to make sure it’s not the connection :slight_smile:

I still haven’t tried the direct connection via cable, but I have seen some issues in the Wi-Fi channel used by my router. I’ve tried a different configuration, choosing one specific channel, and it seems to work, so maybe it could be a connection problem! I’ll make some other experiment in the next days so we’ll see, I wonder why this problem happens only after some updates and disappears after other updates.

1 Like

Sometimes the ISP messes a bit with the settings, it was maybe a coincidence that it happened after the update :slight_smile: