Multiplayer session desynced, then game save corrupted

Game Version:

  • Build: idk
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: OctoberSky

Issue:

A friend and I were playing a multiplayer game on the map gold swamp. Friend was the Tatars, I was the Celts, versing the Goths and Japanese. Our game desynced, which was weird in the first place since we both have pretty good and reliable internet connections.

When we tried to load back in to the lobby, my civilization switched to the Britons and my team changed to a question mark. Readied up and restarted the game anyways.

I was unable to load in and got an error message (sorry I forgot to get a screen capture). My friend loaded in just fine, however my civilization was out of the game, but was still the Celts. I think that the game save corrupted and didn’t let me back in because it detected an error.

I have no clue how to reproduce this, but I feel bad for anyone else who this happens to. Maybe force your connection go bad for long enough to get desynced, then try to crash AoE? IDK.

This has happened to my friends and I every time they time out or disconnect, the auto save file is completely bugged out and corrupted. Exact same issue, changes map, teams, civilizations. I have to constantly save during the match just in case. Game honestly worked fine a month ago