Network adapter disconnect

Game Version: Latest from steam (Asian Dynasties 1.03)

  • Build ((####)) Not sure

Issue:

While I am in a multiplayer game, my network adapter stops working. The network adapter completely disconnects from the internet, and I have to run the Windows network troubleshooter to get it to turn back on. When the troubleshooter runs, it’s fix was “reset wireless network adapter”.

I only experience this issue while playing Age of Empires. I have been on Zoom calls and Discord without disconnect problems.

This issue started around the time when I switched ISPs/router. It was working fine with Comcast; now I am using Ziply Fiber (formerly Frontier’s fiber offering). My router is Google’s OnHub router.

I believe the issue is the same as these ones in the AoE2 forums:

Specs:

  • Alienware 15 Laptop
    • Network adapter: Killer Wireless-n/a/ac 1525 Wireless Network Adapter
  • Ziply Fiber Internet
  • Google OnHub router version 12371.52.22
    • This appears to have a public IP address. i.e. I do not have a modem and am directly connected to the internet

Reproduction Steps:

  1. Enter a multiplayer game
  2. Play
  3. Network adapter disconnects

I tried tethering on my phone, and I had no problems at all. I’m thinking it’s a problem with my ISP or router.

OnHub router settings are:

  • DNS: ISP’s DNS (74.40.74.40)
  • WAN: DHCP
  • Network mode: NAT (standard) mode

I’ve played a few games using Ethernet instead of WiFi, and it has worked without problems. It’s something about the Wifi adapter <> router pairing. It’s weird that I only seem to have this problem while playing AoE, and it’s also weird that I started having the problem after I switched ISP.

It is a pain when stuff doesnt work as expected.

I do not have any ‘field expertise’ in this area, however your error is similar to what I had decades back.

This sounds like incoming signals from outside factors/sources attempts to enter/share the internet connection, AoE3 disconects through “Out of Sync” due to how the wifi-system shares the wifi.

It would appear your new router is as high-tech as an old internet modem, which would cause the internet connection to break upon someone calling in.

Try checking priority settings for AoE3 on your computer.
Maybe AoE3’s run-hierarchy can be raised from your computer and/or your computer prioritised through your Router-settings.

The issue may be that your router needs a new password for the wifi.

This is all I can think of.
I wish your issue gets resolved