New computer, game is unplayable

Just bought a new computer. Tried a few games, all of them are working but aoe2de.

It’s like the mouse and keyboard is freezing up and stuttering. If i open notepad with aoe in background, text would end up like "Thhhhhhhh it loooooosssssssssss ". Same with mouse, so i somehow keep moving the screen when clicking, it gets locked up.

Saw something about antivirus, only got windows and av is disabled atm.

Not sure where to start but i miss gaming…

Windows 11 pro
ASUS ROG Strix B550-E
AMD Ryzen 7 5700G
ASUS GeForce RTX3060Ti
Kingston FURY Beast RGB DDR4 16GB 3200 MHz
Kingston A2000 1TB NVMe M.2 SSD

1 Like

I would definitely re-post this as a bug report if you want to get it looked at.


Thank you, will do that!

1 Like

I had similar problem with my gaming laptop from ASUS. I re-installed game several times and even tried to download patches. Nothing helped me. Almost. Because in the end I decided to use a service that boosts FPS and finally, yes, finally the game started to work properly!