New Uploading Content Bugs


#1

Hello, I attempted to upload my newest custom campaign, and I received an error when submitting “Error submitting mod! Please verify your data and try again.”

I attempted to re-submit a few times and now I see that every attempt created a new entry on the custom content page, despite the error message (the content was uploaded after all). The campaign is called “Alexander in Bactria” and there are about 6 entries now.

I attempted to use the ‘delete’ functionality, but the screen hangs and the files are not removed. I also attempted to edit the entries and re-submitting results in the same error I received previously.


#2

@DodoNotDoDo

Hi @PhillySouljah. Have you deleted your browsing cache?


#3

Actually it really did fail, at least partially. I’ll investigate and will clear out your entries for now.


#4

Yes, I tried IE and Chrome previously, but now I cleared my Chrome cache and I am still receiving the same error when I attempt to upload.


#5

Please try again now.


#6

It’s working for me, @DodoNotDoDo.


#7

And it worked. Thanks again, @DodoNotDoDo!


#10

@DodoNotDoDo I tried to submit a change to my scenario “Labyrinth I” and now when attempting to view the mod it results in a “Sorry! Something has gone wrong. Please try again later.” error.


#11

It’s fixed now. When you updated, what all did you change?


#12

I wanted to replace the original the screenshot of the scenario with a new one, however it looks like both screenshots are now part of the listing.


#13

Can you try deleting the image you didn’t want there anymore? I finally got a chance to look at this further and did find an issue around image removal so it’s hopefully fixed now.


#14

When I attempted to edit my first Labyrinth scenario by clicking the “X” to the right of one of the screenshots and saving changes, I received the following error “Missing required fields (GameTitleId). Please check your entries and try again.”


#15

Sorry, can you refresh and try again.


#16

It accepted the removal of one screenshot however my scenario still shows both screenshots after clearing my browser history and cache.


#17

It was stuck in an odd state so I had to remove them (I can’t edit yours). If you re-upload your correct image it should work now.


#18

So I should edit my scenario, clicking the “X” next to both screenshots and upload a new screenshot, save edits and then there will only be the new screenshot displayed on my scenario page?


#19

There should be no images at the moment, so just uploading the one you want.


#20

That said I’m also seeing another issue with one of the backend services right now so it’s possible you won’t be able to edit. Let me know if not and I’ll let you know when that appears fixed. Sorry for the inconvenience here and I really appreciate your help!


#21

You should be safe to update now.


#22

It took my new scenario screenshot. Thank you.