New Year's Challenge Advance to Castle Age from Dark Age in 21 mins

Good morning.

Is anyone else experiencing problems with this challenge? When I play it there’s no timer and I have gotten from the Dark Age to Castle Age in under 21 mins 3x times now. Twice yesterday and once today. I’ve even timed it with a stopwatch to make sure it’s under 21 mins. I’ve been 5 mins to 7 mins under and yet the challenge never completes. I have the new update 101.101.44834.0 installed now as well.


I completed it just fine. after clicking the “begin challenge, single player” option just check empire wars setting for fast economy set up and kill the ai, you should complete the entire mission in under that time. post a video of the entire attempt if your still having trouble so we can figure out what’s wrong.

1 Like

I played with ultra-high resources and I still won.

1 Like

Thanks for letting me know there was a new update, it was really helpful.

1 Like

Thanks to you both! I didn’t think about changing any settings to get it to work as normally I don’t have to do that. So, I changed these settings… victory: timed limit, time: 300 years (25 mins) and end age: Castle Age. Challenged completed. :slight_smile:

Thanks again for both of your replies. They got me thinking in a different direction. :blush:

Hey guys, i have the same problem with this Challenge, i tried diffrent ways to complete it but no success :frowning: i dont know what i am doing wrong :confused: tried victory with limited time to 300 years and with end age: castle age and in Empires Wars setting, still nothing :confused: any tips ?

Hi Paulhascilo. In using the same settings I did that you mentioned. Are you positive you completed the goal in 21 minutes? 300 years setting is 25 minutes long. So, you can’t cut it close. You have to have at least 48 years left on clock. I’d aim to have no less than 50 years left max. 21 minutes is around 252 years of the 300. However, when I did this I also used the stopwatch on my phone so I knew, time wise, where I stood.