No ELO awarded/lost after ranked 1v1 random map game

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 7126076
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Following installation of Dawn of the Dukes DLC, finding ranked multiplayer games has become very difficult, with timeout errors/failure to create game etc. Not the point of this report, but possibly useful context.

However, this ticket refers to what happens whenever a game DOES occur - no ELO change is displayed following the game, and no record of the game is found on third party sites like aoe2 dot net.

I have verified that I have no windows updates pending, my internet works without any apparent firewall conflicts, etc. This problem only appeared about 24 hours ago, a couple days after installing the DLC, and persists through restarts.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

Here are the steps to reproduce the issue:

  1. Somehow find a ranked game that starts successfully, despite horrendous issues (again, not the point of this report).
  2. Play a ranked game, win or lose. No ELO awarded/lost on post-game screen, nor afterwards.

:arrow_forward: EXPECTED RESULT

ELO gained/lost, results visible in profile and on reliable 3rd party sites.

:arrow_forward: GAME FILES (SAVE / RECORDING)

I attach two ranked 1v1 games played via online matchmaking queue within the last 24 hours, no ELO awarded after winning, games don’t appear on AOE2 dot net. The replays still exist in my saved games folder.

  1. MP Replay v101.101.51737.0 @2021.08.15 112403 (1).aoe2record - Google Drive
  2. MP Replay v101.101.51737.0 @2021.08.14 124728 (2).aoe2record - Google Drive

Update: ELO for one of the two games just came through, after a delay of several hours. Still nothing for the other. Something about the ranked matchmaking is clearly not at 100%

1 Like

HOURS ?! Lol okay.
Well at least it kinda works… Did you get your second game’s puntos ?

It looks like it was my second game that was recognized…not the first one from yesterday. So I dunno what’s going on lol

The same happened to me 2 months ago in a ranked Team Game. Created a post here and nothing happened. So annoying =(

It’s a UI bug. You end up getting the elo, but it doesn’t display after the game.

Just had the same thing happen to me, after playing a ranked game on Arena. My total game count, ranked game count and win count also didn’t get updated, neither in-game or in websites like and I’ll update this reply after my ELO gets properly adjusted.

EDIT: After 10 or so hours, my ELO still hasn’t been adjusted. On a side note, my opponent on that match has since played a few more ranked games, and on the mentioned websites, they all count as being concluded games, where as this bugged game does not.

Hey everyone,
this issue is currently being tracked, thanks a lot for the report!


got the same problem, wins are not counted, but losses are

Hi, same for my account - AOE Nexus | Profile

Second update: This is the complete history of the matches I’ve played since installing the DLC, from this site (AOE Nexus | Profile). Two of the games appear with the result “UNKNOWN;” I won both, but there has been no change in ELO. The other games I won had their ELO come through between something like 15 minutes in one case and 5 hours later in another. I’m not actually clear if the game I lost caused me to lose ELO or not. If I check my profile on AOE2 dot net, the UNKNOWN games in question don’t appear to exist.

Still the same for Shashlyk account, after the game I cannot see my opponents’ 1v1 ELO. Then, for victories I don’t get any points, for losses I do lose the points.
I tried to play with another account and it works perfectly fine, the problem affects only the specific user ID. Steam ID: 76561197999797448