No mills?

I just was in the Scenario editor and there is no Mills only Folwalks.

Has anyone else notice?


In my costum map all mills have been replace by Folwalks.

I can not find any mills, I try changing civilizations just in case, but no, there is no mills.

However when I tested the map, it went back to mills…it is just no mills on the editor.



…but seriously, I checked just now and you’re right: the scenario editor won’t let you place Mills. It’s just an oddly specific glitch that I can’t help but laugh, but this can easily be a real issue for scenario makers. Hopefully the incoming hotfix will fix this.

1 Like

And I’m not finding Cavalier. Changing age and civilization are giving me either knight or paladin, but no cavalier. I thought I was really bad with scenario editor. But now it seems like a bug.

I wonder if this is OS specific? I don’t see any issues placing any of these objects (Windows 10 Pro):

Edit: On further investigation, the visual glitch appears if the mill belongs to a player in Castle or Imperial Age. If in Dark or Feudal, mills appear as mills in the Editor.

1 Like

It happens only from castle age on. At least for me. In dark and feudal age you get normal mills. When you test the scenario however everything seems normal.
Don’t know about cavalier, I’m gonna test.
Very annoying but since there are less scenario makers than common players I imagine this will take more time to be tracked and fixed.
Another scenario editor issue is that you can’t anymore place water terrain without beaches around.

1 Like

Not likely, in my experience. Editor stuff in general seems to be very low priority even for major patches, much less hotfixes. Then again, this one is probably simple enough that they could fix it quickly if they wanted to. On the plus side, it’s just a minor visual inconvenience, and nothing really gamebreaking.

Yep, still waiting on the latest Modify Attribute fix, among others, which has been waiting for 5 months (after the one before that was waiting for a few months, and the one before that was waiting for a few months…)

Don’t know if it’s your issue but they should make that you can modify attributes of renamed objects. I wouldn’t waste time on useless triggers to workaround it…

Not sure what you mean. I was referring to the HP bug (also present with Replace Object). I saw something in the patch notes about renamed objects, but to be frank I’m not sure what it was referring to unless it’s specifically referring to objects changed with the “Change Object Name” trigger, which I mostly don’t use (specifically because you’ve never been able to use Modify Attribute after you’ve used Change Object Name).

I’ve noticed visual glitches like that when I watch replays in-game (not capture age). Half of buildings still look like dark age in feudal or castle age. And red and blue colours are sometimes swapped on some buildings or half blue half red.

Aaaah that one. Well that’s pretty easy to workaround, just heal units that have been swapped or modified through the healing effect.
I don’t even know if the replace objects with lower HP is supposed to be a bug or might just be a conscious decision because when I substitute a unit for another, for example, to make it get on an horse, it makes sense that the unit doesn’t heal automatically.
But for the modify HP yeah it probably shouldn’t be like that.

Thank you for the info…in that case I would edit my scenarios in the feudal age, then move it to the Castle or Imperial age.

And yes is annoying but I thank you for the workaround for the issue.

1 Like

Been doing that, but it’s far from a full solution. If you modify HP on a lot of units and/or have promotion mechanics like I use, it’s a lot of extra healing effects or triggers. And kind of janky using this as a workaround for the Replace Object bug since you either have to limit it to a very small area, or superfluously heal units that aren’t being replaced. I’m glad there’s a workaround, but I don’t like needing 50+ triggers in my 500+ trigger scenario to be workarounds for various bugs.

It’s a bug for sure. It doesn’t make sense for a full-health Man-at-Arms to get on a horse and suddenly become a gravely wounded knight. Also just a major inconvenience if you’re trying to replace anything with a unit that doesn’t have exactly the same HP. It’s also a problem going in reverse - using the unit to horse example, if a unit dismounts to become a foot unit (e.g. knight to M@A), it will have 100/45 HP. So yeah, not the worst of all bugs, not as bad as when Modify Armor/Attack were broken, but more than a little annoying.

Also, for this I would just use Modify Attribute → Object Name ID, since you can still use modify attribute. TBH I don’t know why anyone still uses Change Object Name unless they specifically don’t care about modifying the unit. It’s just a worse version in the same way that Change Object Attack is a worse version of Modify Attribute - Attack (and TBH I have no idea when Change Object Name ever worked with Modify Attribute, as it never did at any time when I tried it in the past couple years).

The trick I use to make change object name work with modify attribute is to make the modify attribute trigger start from the beginning while putting the change name one in a loop of 5 seconds. In this way the unit gets its stat modified first and then it changes the name.
But it’s not very elegant because you can see the original name at times, I’m just stuck in my ways lol.
Which campaigns did you make? Maybe I already played them.