Not possible to pick civ in Quick Play anymore?

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: ######
  • GAME PLATFORM: Steam /
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:point_down: DESCRIBE THE ISSUE IN DETAIL (below). LIMIT TO ONE BUG PER THREAD.

can’t see an option to pick a civ in quickplay either before clicking enter queue or once game has been found. More than happy to just be missing it, but can’t see it.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • Less than 25% of the time / matches I play (RARELY)
  • 25% of the time / matches I play (SOMETIMES)
  • 50% of the time / matches I play (FREQUENTLY)
  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. hit quick play
  2. try and pick a civ

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

Hi @Leshanni

Thank you for your bug report, i am unable to reproduce this unfortunately.
Could you please verify your game files, and make sure you are on the most recent game version?
Verifying game files can be done through right clicking the game, properties, local files, verify integrity of game files. live game version can be seen on the main menu at the bottom: Version 101.101.62085.0.
Also disable any mods if you have any installed.

I can confirm this is the version of the game I am using. Steam is set to “keep up to date” on updates tab. I hit verify integrity of game files and all 197 files successfully validated. Here’s a video, I have disabled every mod I have.

Hey, thank you for your video!

I noticed in your video that at the main menu, you are missing even your profile icon, which is also strange.
I recommend a full reinstall of the game, steam and update your graphic drivers if they are not already up to date.
If the issue still persists after that, then you could consider contacting support.

https://support.ageofempires.com/hc/en-us/requests/new

Good luck!

1 Like

Just to check, you want me to completely reinstall Steam as well as Aoe2?

Hey,

Yeah I do mean both the game AND the steam client.