Object selection is broken in new patch

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 81058 (10944061)
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


When I try to select tree, or pallisade wall, or villager, or sheep, I often can not. Sometimes the only way to select pallisade wall (to delete it f.e.) is to create one more wall and shift+select. Gathering point - same issue, I can not select correct position. Trees - i can not shift+click to next tree. All this had place in previous patch too, but aftre last one, the troubles are in almost every game.

Also in new patch it’s even more hard to select large object like house and deep-fish. It’s not enough to click on area 2x2 i need to be more precise.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:


  1. Build lumbercamp close to wood.
  2. Try to select each tree which is close to lumbercamp.
  3. Try same on the hill.

Pallisade wall example (but not the only one):

  1. Build tower.
  2. Build 8 pallisade walls around.
  3. Try to select each one.
    Other experiment: try to select every tile of pallisade in enemy two-layered wall.

Gathering point example:

  1. Try to make box with 3 pallisade tiles behind the tower (to repair and being safe).
  2. Try to bring out a villager from tower into this box.
    Other experiment: try to eject villager between your tower and enemy wall.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

I can select each object i want. I do not need to dance with a tambourine around each tree/wall-tile to select it.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

Can not select tree.

Can not select pallisade.

Can not select gathering point.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

MP Replay v101.102.15522.0 #(81058) @2023.04.23 080251 (2).aoe2record (4.4 MB)
timestamp pallisade: 11:00
timestamp gathering point: 13:38+


It seems they released a pup fixing this issue

1 Like

We’re already aware of that issue, thank you.

1 Like

Hotfix 82587

  • Fixed an issue where walls always had lower selection priority than nearby objects.

The issue is still not fixed. I note it only because of hotfix, which says “it’s fixed”.

Can not select wall-tiles.

UPD: Hotfix was about walls. But all cases of the issue are still not fixed. Moreover, one more case: can not select villager near mill to attack it.