"Objects in Area" trigger not working

  • GAME BUILD #: Since the beginning
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

When creating a trigger in the scenario editor there is a condition named “Objects in Area”, when you pick “units” and object list “” it will assume any unit will do, that works, however, if you try to change it to “buildings”, “heroes” or “others” it will go back to “units” if you select “” making it impossible (for example) to place a hero in an area and make that hero be any of the available ones.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!
Here’s the steps to reproduce the issue:

  1. Open scenario editor
  2. Go to triggers and create one
  3. Set condition as “Objects in Area”
  4. Set “Object List Type” to anything but units
  5. It will reset to Units when saving or testing or even clicking somewhere else

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
Pick “heroes” and make that select all heros available, you can also try to do “Object Group” as “Hero”, doesn’t work

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

It will ALWAYS revert back to Units


Thanks @XavierTenka.
We’re now tracking this issue :slight_smile:

1 Like

Has this been really acknowledged? Haven’t seen it in the “tracking” or recent patches…

This is not a real bug though, it has been like so since the very launch of AOK. If you don’t specify any other field than the “Object List Type”, this field will systematically reset to “Units”.

To deal with this, set something in “Object Type” and/or “Object Group”. Then then Object List Type will be locked.

Thing is I wanna set it to “heros” any will do, not a specific one but anything that is a “hero”, doesn’t work with it. It worked before tho. Pretty sure since i’ve made maps for quite some time

1 Like

In that case, make two conditions for the trigger, add a “Condition Joiner” (OR) between the two.

Select “Heroes” in Object List Type for both condition.

In the first condition, set “Military” in “Object Type”. In the second condition, set “Civilian” in “Object Type”.

Heroes will now be locked in both conditions, and the condition joiner makes it so all Hero types are ruled in by the trigger (civilian & military).

Hey, I tried to replicate the issue myself, and it happens you’re 100% right, it is completely bugged indeed.

No matter what you state in other fields like before, the Object List Type never locks.

It is another issue needing a fix then.

1 Like

Thnx, it sux cuz there are many map ideas depending on that trigger, Idk if its possible but there should be a trigger of “units closer to X tiles” get certain Effect, would be nice in campaigns

I guess it will be fixed in the next update.

What do you mean by “units closer to X tiles”?

For example if any unit is 5 tiles or less close to a villager, it can get an effect, usually the way I do it is
Object in area condition → Activate trigger effect-> Objects in area → Heal units, but doing this for all the tiles in the map tires me 11

Ah yes, basically a larger (switchable value) “Bring close to Object” (selectable or by type).