Oct 6 release for Steam, but not MS Store

There’s a new Steam release for AOE2 this evening, which comes after yesterday’s Steam and MS Store release. Today’s Steam release appears to be a hotfix.

But, today there’s no MS Store release. When will it be available?

Furthermore, there’s no announcement anywhere about today’s hotfix.

Me neither have the ms store patch but got the update on steam, so i can’t play co-op with my family because of the different game version >.<

11 just got it working.

Option 1: If you have the XBOX app installed on Windows, uninstall it. Then go to Microsoft Store, re-install the XBOX app, then find updates and the AOE2 updates should show.

Options 2: If you do NOT have the XBOX app, install it through Microsoft Store then find updates.

works for me! thank you very much!

1 Like


Hey, unfortunately it does not work for me (although it worked with the last hotfix, 2 weeks ago).

Tried option 1 twice, but still no hotfix. I’m still stuck on version 54684 (instead of 51737, which should be the correct one, right?).

How did you uninstall the App? Using a function in the app or via the Windows uninstall function? I used the latter because I couldn’t find another.

Any ideas?

Kind regards, Benjy536


You’re on the right version now :slight_smile: 54684 is the latest.

I also used the standard Windows uninstall, by the way.

1 Like

Ok, just realized that 54684 is a higher number than 51737… :laughing: