One bad day too many

Yet again another largely pointless update brings game crashes and a host of new bugs. Five attempts to complete my very final mastery (Abbasid ToS IV, not that it matters) twice crashing an hour into the game, two more crashing just because I paused it briefly and the final one I actually got finished … only for the game not to complete the mastery and believe I was playing on Dry Arabia when it was in fact Black Forrest! (No idea if that ‘new’ bug was the cause.)
(Btw I have a nearly new and highly spec’ed set up, so no issue there.)

I have perservered as an age fan from the start, Cats and Ellys mayhem on a 56k modem! But, AOE4 is an insult to us all … £60 for a nice looking but far from complete game full of bugs, poinless updates continually failing to address most of them whilst creating new ones … and worst of all, with the gameplay depth of a puddle of water. I’m done, way to kill a franchise MS, gg.

Note for streamers - Stop riding on the back of the money MS keep pouring into tourneys to try to prop up this shite and have some respect for your audience, call this travesty out for what it is and something might, just might, get done. (T90, althought you are far, far too polite to fully say what needs to be said, you at least try in your own ultra nice way, you are not included. Long may you champion the star of the series, decades out but still running rings round this snivelling excuse for a game.)


I played over 400 hours on game pass for free, completed all campaigns and masteries. Crashed only 2 times in multiplayer due to a know bug when placing a landmark.
So check your pc instead of blaming the game…

So have you solved your problem with your experience? I guess yes.
And with such experience why you pay for something than can be played for free?

Wait, is PC GamePass free somehow? From what I can tell by looking at the Xbox website it’s $1 for the first month and $9.99 per month after that.


Like shooting fish in a barrel. I think he/she is best left to their musings, venerable TW

In the 6 months since AOE4 came out, I’ve probably only crashed like 2-3 times, and I’ve been playing on a laptop. I dunno why you’re crashing, but try turning your graphics settings down for improved performance.

And I have no idea what “pointless update” you’re talking about. The last patch was a few weeks ago, and I’m pretty sure no new bugs have been discovered from that patch


If you wanted to illustrate you have no understanding of the nature of bugs then you did well, otherwise a generous 1/10 for effort.

With Microsoft rewards you can do daily task and gain enough point for take a 1 mouth pass pc for free(you need 6800 points). It’s almost an year that I have the game pass in this way without spending. It takes less than 5 minutes to gain around 200/250p at day… In an mouth are enough for take the reward:)

Would you like to give specifics on these bugs/file a bug report? Because otherwise I have no idea what you’re talking about

I have had similar random crashes on a new setup. Solution for me is to re-download the entire game each time there’s a patch. Maybe that could fix yours too.

keeping playing on gamepass is hurting aoe franchise as a whole as you keep supporting bad practice like op refers and everyone here suffered since launch

I disagree, I’m sorry for you

Tried that multiple times over the months, Taishar, like I said I’m an IT expert - no joy unfortunately. Glad it’s helping you though … if a little annoying to keep re-installing.

1 Like

Sorry to hear of your troubles, you seem very knowledgeable and especially eloquent, so hoping you won’t let these bugs make you give up on aoe4 altogether.

I still regret having spent 900 euros on a new videocard for this game…

With a 900 eurocard you can play a lot of others game, so don’t be worry, you have multiple choice of fun :blush:

Thanks Taishar, as it happens my years of experince have served me well … turns out it was an age-old legacy USB confict.
Unbeknownst to me my visiting daughter had plugged her Apple watch charger into a rear USB port on my gaming laptop which I only noticed last night. Removed and crashes disappeared, plugged it back in and same issues returned. Sorted :slight_smile: … doesn’t alter my opinion of the game so far unfortunately.

AOE4 150