Passive AI in campaign

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 100.12.13490.0
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

The AI seems very passive in some missions. In the mission “Fountain of youth”, it did attack, a little, playing on hard.
In the mission of Act II “Defend the colony”, I had regular, scripted attacks of Cherokees making it for my city, but it was nowhere near as impressive as in the original game where I would often struggle to keep my towers alive as there were constant waves of Cherokees.

Notice that in these two games, the attacks were staged/scripted to specifically happen at these moments, not part of an overall strategy from the AI to build troops and send them at me.

Now, in this current mission Colony in Ruins, it’s basically sitting there doing nothing. There is the occasional scout roaming the map. Villagers are sent to gather gold or food near my base, where I can easily slaughter them. The army stays in the village, no new troops are produced and sent after my town. Again, in the original game, this mission gave me a lot of trouble on hard. I think I even needed to play that one on medium difficulty to succeed. This is a far cry from the original AI.

I think the AI only attacks when it is scripted to do so with units appearing out of thin air, not units it will itself produce as part of a regular game.

I am posting this bug here because this is exactly the same behavior I noticed when I first tried to play the game when it was released. I have read since that there were multiple improvements made to the AI, but I guess it was only for MP. A little love for the SP side of things would be in order too, thank you very much.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

So far, it happens in the three times I restarted my scenario.

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Play the first part of the game where you destroy the Cherokee’s huts and meet their leader.
  2. Play as you would play any campaign game.
  3. As long as you don’t enter the line of sight of the main army group sitting in the base, the AI will not send wave of troops to attack you, or try to destroy your city.
  4. If you do get into its line of sight, it will send all units it currently as, but will never build new ones.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
I would have expected, as per the original, that the AI would try to mount attacks with its musketeers, archers and cavalry to try to destroy my city, attack my walls, my towers and my castle, as it did in the original. I would have expected it to be even smarter than in the original and try to find weak spots, gaps in my “chainmail” to attack. Nope. Nothing, unless I attack the city or the units stuck in it, it will not react.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe3Ysav) or GAME RECORDING (.aoe3Yrec) of the match where you encountered the issue. Link it below if using an external file service.


Thanks for the report!, this issue is currently being tracked

I’ve been away for a while… As there been any progress on this issue? Could anyone here who plays SP campaign tell me if it was fixed? I can’t see anything related to this in the patch notes for Frebruary and March.


Is this still being tracked? The AI in many campaign seems to be really passive even in hard difficulty.
Sometimes they even seem to gather their troops at a certain spot on map with no apparent purpose.

For example, in the first chinese campaign mission, the AI would gather their troops at the neutral allied dock (yellow dock, the one just on the left of the player base) and do nothing else.

Thanks for the effort for AI changes in the PUP though. Seeing it still being worked on feels nice.
It would be nice to see improvements in campaign too!

1 Like