Problem with mods overriding files linked to material.json

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 87863
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

I experience an odd ui issue with mods and I don’t know if I am the only one who experience this. Because if the problem is not on my side, then it affects a lot of mods subscribed by many players.

The overall issue is that some ui mods do not work. More specifically, any ui mod (wether it’s a local mod or a subscribed mod) that contains a string refering to some info in the material.json file in …AoE2DE\widgetui folder does not work.

To test it out, I downloaded some ui mods. For an example, if you subscribe to Better Blacksmith Icons, the mod just does not work for me. I see the original blacksmith tech icons. Note that that contains the new image of the icon of that tech has its filename referred in material.json.

I subscribed to another mod: Mods Single - Age of Empires (halberdier reskinned to heavy pikeman). The mod partially works: the real ingame unit is properly reskined, but not its icon. Note that there again, the icon of that tech is in 104_50730.DDS file and that this filename is referred in material.json.

I personally noticed something is wrong when I created a mod with a file that overrides the \AoE2DE\widgetui\textures\campaign\rcam2\, but it just does not work, the background does not change. Yet again, “” appears in material.json

:arrow_forward: FREQUENCY OF ISSUE

There is no randomness with this issue.

:arrow_forward: REPRODUCTION STEPS

Download any mod that overrides a unit icon tech icon, or a campaign background, etc. Any mod that overrides any file with a name mentioned material.json. You can try it with the mods I mentioned above. And see if it works

:arrow_forward: EXPECTED RESULT

Mods should work.

Now I wonder if that might be a problem that is on my side only, because if it is not specific to my installation, it ruins a lot of mods out there, and it would be weird that nobody noticed anything.


Oh never mind, I just found that by disabling my other mods it solved the problem, it seems that the problem was on my side, yet I need to investigate more to understand what happened.

Consider this as solved for now.