Problem with own mod (data mod)

Hello fellow modders,

I recently finished my first data mod. Before I uploaded the mod, I tested it again offline in single player and it worked smoothly. Both the data mod was recognized and the functionality was correct.

Then I uploaded the mod under “submit”.

Now we come to the problem. The mod can neither be downloaded from the page nor in game under mods. if you subscribe then the game loads the mod permanently until i restart aoe, but after restart of the game it was downloaded incorrectly because it is not recognized as a data mod and accordingly has a checkbox like other non-data mods.

To test whether it is due to the mod, I uploaded a working data mod from another modder (private as a test) and the same problem happens. So it’s not the fault of my mod.

My friends and I tried to download the mod and it didn’t work for anyone. Of course I wrote to the support, but they said that it worked for them (probably faulty with a checkbox and not tested ingame).

The mod is called “QoL Mod by Radox”

I hope that someone of you can help me, please!


I downloaded it and the game doesn’t show it as a data mod (just the normal check-mark).

The other data mods work fine and I can chose them from the drop down menu in single player etc.

That’s my problem.
I tested it with a mod (from other modders for testing purposes) that works as a data mod. But when I uploaded it (privately of course because it’s not my mod, just for testing) then the same problem occurs. Also this well working mod is shown as a check mark, not as a data mod (wheel gear).

Do I have to consider something before I upload my mods?

Thank you for helping a bloody newbie in modding :slight_smile:

a checkmark is usually to do with UI, graphics or campaign.

if yours include datamod, specifically includes the empire.dat file then it needs to be separated into 2 mod and upload both.

you can take a look at how AOE2DE GOLDEN did his. the UI and data mod are separated, it is the only method to work for now.

Ah, I looked at your file paths again and I think this might be the problem:

The top one is a working file path and the below one is your file path. You have to remove the underlined part with the arrow in red. Then try again to update, I hope that’s all there is to it.

1 Like

Oh thanks a lot. I will test it if Iam able to upload a mod again.

This is the error that occurs when I try to upload a mod right now.

Maybe a server issue, just try again tomorrow.

It’s finally working. Thanks alot!
Without you I would struggle for more weeks.

Again a big thanks by me :slight_smile:

1 Like