PSA: You can fix the TREES LOD POP-UP with this setting

I see many have this issue with Trees level of detail swapping when you zoom-in and out.

Many pre-release youtubers pointed out this issue too.

The way to fix it is to set “Geometry Detail” to “maximum”, you all probably have it to “High” without realizing there is another setting above.

Also you need to restart the game.

Have fun