[PUP] Game Crashes Build #98162

My game crashes after the splash menu for PUP. No logs created on crash, main.txt empty. I was able to launch PUP yesterday (23-11) just after download but today (24-11) it is not starting anymore. Tried file verification, didn’t resolve.

Reverting back to Build #95810 fixed the crash.

My PC specs
Ryzen 7 5800H 16GB Ram Nvidia 3050Ti

1 Like

Hi @Juggernaut8704
Are you using a third party antivirus?

Nope just the windows defender that too with real time scanning turned off. I tried reinstalling PUP but it still isn’t launching.

Here’s a video depicting the problem:

Do you have Steam, Nvidia or Discord overlays enabled? If so, try disabling them. You could also try adding the paramater SKIPINTRO in Steam as a temporary fix, it might work.

from my experience, usually this is to do with missing or outdated window libraries. visual studio etc?

@Juggernaut8704 try running directly from the .exe itself and see if theres any error message coming out of it.

It would have been helpful if you showed what programs are running in background, like windefender, antivirus, discord, etc.

You have some disabling to do + Running steam as administrator:

  • Disable Windows defender “Real-Time Protection” & “Tamper protection”
  • Disable or preferable uninstall an antivirus if you have one (Bitdefender, Norton for instance are known to be very aggressive even if you disable them they still block things). Some antivirus come with overlays so disable them or pref uninstall.
  • Immediately and completely uninstall “Malwarebytes” if it’s on your system as it prevents exe files from writing to disk even when it is closed.
  • Close discord or any communication app (or disable their overlays)
  • Uninstall Nvidia Experience but keep the driver (has an overlay)

Now run steam as admin and then run AoE2 DE (you will get a prompt to confirm running the game as admin just click yes) Now fingers crossed you should get the logs.)

If not it should be a mod(s) preventing the game from getting to point where it generates logs so follow this guide to remove them https://ageofnotes.com/resolve-issues/fix-age-of-empires-ii-definitive-edition-encountered-a-problem/)

We may need hijackthis log to see what is hooked into explorer.exe too if the problem persists.

Hi there, does the crash still reproduce in PUP build 98674?