Q: I was invited to the beta but I can't access the beta forums!

I was invited to the beta but I can’t access the beta forums!

If you received an invite to one of our betas but are unable to access the appropriate closed beta forums linked below, please follow these troubleshooting steps.

Troubleshooting Steps:

  1. Check that you are signed into the forums with the same email address and Microsoft/Xbox Live account that you used to sign-up for the beta
  2. Log out of your forums account
  3. Clear your browser cache and cookies
  4. Log back into the base Age Insider forums
  5. If you are still unable to access the forums, post below on this thread or email us at AoEInsiderSupport@microsoft.com. Please indicate the beta you were invited to, so we can efficiently reply.

Please post all other support questions regarding the games in the appropriate forum and category. Thanks!

Note: If you were part of a beta that is now closed, we will not be troubleshooting access to its former forums. Thank you!

2 Likes

Howdy! I got a Beta key but when I try to click on the forum link in the email it says that it’s private. Do we need to contact someone to get permissions?

1 Like

I’ve got the same problem here

clear your browser cache, should work after that.

I can see it, I can reply… but how can i post a new topic or question?

the bottom right you should see a plus sign to add a new topic when you scroll down. make sure to be on the topic page.

DUH! thank you and i work in UX! lolz

clicked link in email and in other threads posted here. None of them work. Keep saying page doesn’t exist or is private. deleted cookies and cache and still not working. what do?

Has the forum for AoE2 DE been set up yet? Whenever I click the link in my email it brings me to a page that says “Oops! That page doesn’t exist or is private.”

Welcome here. You will need to clear your cache, cookies and restart the browser. After doing that you should be able to get there. Make sure you disable popup blocking in your browser too as the forum’s login screen is (still) targeted to a new window.

I’ve done this and also tried multiple browsers on different devices, still not working, getting the same message every time.

Is this regarding (1) registration for the beta or (2) regarding response to the invitation to do the survey or (3) regarding the link that is send when invited to join the beta?

I hope Im not breaking any guidelines by posting this about the Beta but I cant seem to either figure out how to contact any admins or moderators, perhaps I just cant. Either way I am unable to access the private beta forum that was emailed me and I am not sure if it is bugged or what. Please help!

This was regarding (3)

The link RadiatingBlade posted worked for me

2 Likes

Hello Mods,

I’m not sure how to get access to those message boards but I’m currently in the closed beta and would like to provide feedback. Please advise. Thanks!

You may need to clear your cache and cookies, restart your browser and sign in again to the forum in order to access the beta section. If you have cached your login credentials you could also try to sign out and sign in again to the forum. The access to the beta forum might be granted at your next fresh login.

3 Likes

Please see the post above for beta forum access help.

Did you receive an invite to the Age of Empires II: Definitive Edition beta and need help accessing the beta forums? The beta forums can be found here.

If the link above results in a page which states the page doesn’t exist or is private, clear your browser cache and delete cookies or open a private browser tab and then sign back into the forums. Make sure you are signing into the forums using the same Microsoft Account which was used to register as an Age of Empires Insider.

If you need additional help, please leave a comment below. Note that since the Age of Empires II: Definitive Edition closed beta is under NDA, only post about the beta in the beta forums. If you post leaked material in any public forum you may be removed from the beta and not considered for future testing.

1 Like

Hi, my steam download for the beta is on a never ending loop of download. I followed the instructions i got in the email 100% but once the download is finished, and it wants to launch, it will stop and re download the entire thing again.

I’m in the beta and it is saying its private and cannot access the forum.

@Berserker41 @BepBeepImAJeep1 Check your private messages.

1 Like