Replay of Nomad Game Error

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 101.101.56005.0.7694700
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

When you replay a game which map is nomad, then error exist “Out of sync replaying game. This is usually caused by incompatible game version or data being used. Replying stopped. world time: 10716”. But the replay game all after the update 56005.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Do a game which map is nomad, whatever single or multi.
  2. Replay
  3. when continue to 15sec in game, then get an error

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.


Thanks for the report, but for a proper investigation we would need a recorded game. Really helpful would be logs or minidumps in case of crashes as well.

Minidumps can be found in “C:\Users\USER\Games\Age of Empires 2 DE\logs” will have date-time format, something like “AoE2DESteam-51577-2021.10.07-10.11.24.mdmp”, it should be at end of the folder.

And logs in the same folder with a different name.
Could you try unsubscribing to all your mods and trying if you will be able to reproduce the issue. Have you tried verifying the game data or reinstalling the game? Does this happen for other maps as well?
Thanks for all these answers

AoE2DESteam-56005-2021.11.21-00.05.30.mdmp (305.0 KB)
Well, this is not a crash, so the .mdmp file seems unused, it just appeard in record error. And here are we have a nomad game last night, so im sure the game is in latest version. And i unsubscribing all mods after watch this.

This error just appeard in nomad record game, 100%. As for others map like araba is not. I guess the reason of this maybe nomad game after update have “5min Treaty”. And i want say this setting is foolish because man can guess enemy position from the yellow line.

Have you tried the thing i said above? We will look at the minidump :slight_smile:

i tried but still error

I have the same problem. This is the recordAgeIIDE_Replay_131098965.aoe2record (1.9 MB)

Same problem, at least twice in ranked TG, second game was land nomad, first probably regular nomad.

how old is the recorded game pls? because it could be caused by trying to watch a game from an old patch, that is not compatible, but that is by design

Did you read the thread? Of course we are all having problem with new and fresh recorded games, and all players have the same bug caused by the latest patch.
Simple bug, simple description, easy to reproduce in any pc.

This is under the current new version

Hey everyone , thanks a lot for the report and extra information, we were able to repro and we are now tracking the issue.
Hope youll have a nice day

Same problem. Every nomad game.
MP Replay v101.101.56005.0 @2021.12.19 152529 (1).aoe2record (1.7 MB)

Hey, any update?

It happens only on nomad maps.
Some replays are not affected, but most of them are broken.
It looks like related to the first town center (e.g. logged as built, but rejected in game due to terrain conditions).

I experienced this bug as well. A shame; I really would have liked to rewatch the game from the opponents perspective. :frowning:

Any update on this? Still same error on all nomad/land nomad games.

There is one more thing: the timestamp of the recorded game appears to be about 6 hours in the future.

It looks like the file timezone is always GMT, while I’m in EST.

It’s funny to see how a recorded game is “about to happen in a few hours”.

I tried to change the date on my PC, but the recording still goes out of sync.

Hi @UltimaGaina !

Thanks for pointing out his timestamp issue, we are now tracking it :smiley:

african clearing map also has this bug

I have the same issue - most nomad replays go out of sync. See attached recording.
MP Replay v101.101.56005.0 @2022.01.30 155439 (1).aoe2record (1.6 MB)

This was supposedly fixed in the patch, but it wasn’t (in unranked at least, not sure about ranked).