Replay of Nomad Game Error

Hi @anon642a !

We could not reproduce this issue anymore, could you add a recent record game where this happens?

Thanks!

SP Replay v101.101.58850.0 @2022.02.15 021626.aoe2record (2.1 MB)
MP Replay v101.101.58850.0 @2022.02.13 214452 (3).aoe2record (3.5 MB)

Some of the replays of other treaty games do work, don’t see any obvious pattern of which ones do/don’t.

Thanks for this!

I have added your files to our ticket ヾ(^∇^)

1 Like

I’ve also got a game where this occurs. The game was played today on ranked queue.

It seems that the game has an error with the replay when a garrisoned TC killed an enemy villager while the treaty countdown was in place. Note that the reason the enemy villager was close was to try to lure a boar directly adjacent to the aforementioned TC.

MP Replay v101.101.58850.0 @2022.02.20 203440 (3).aoe2record (3.6 MB)

My suspicion is that it has something to do with the fact that during a Nomad game Replay, the “treaty” doesn’t end when everyone finished building their TC. During the actual game, the treaty ends before the timer runs out when everyone is done building their TC, but when you go and replay that game, the treaty is kept on until the timer runs out.

Here are 2 replays, games were played consecutively the same day (Feb 20th 2022), first one goes out of sync right as the treaty timer runs out, second one doesn’t have a problem (but the treaty timer still goes on after everyone built their TC)

Failed Ranked Nomad Replay.aoe2record (2.6 MB)

Working Ranked Nomad Replay.aoe2record (2.1 MB)

2 Likes

That makes sense to me. I posted a replay where I killed a villager within my yellow square by garrisoning my town center.

Before the de-sync, the replay implies that the treaty was still in effect when the villager was attacked. Perhaps in the actual game, the treaty had ended as all TCs were up.

1 Like

Hi again!

Thanks for these new files, I have added them to the ticket too ^-^

Hi, posting again just to confirm that the bug is NOT fixed.
It happens in most nomad games and is still very easy to reproduce.

Posting to remind everyone that as of today, 18 March of 2022, the bug is still not fixed.

Still got crashed when trying to view Land Nomad Replays.

To reproduce, simply play any Land Nomad game and the game will crash early in the game.

+1

I play mostly team nomad ranked games, I usually like to watch some replays of intense games, and its a shame when they just crash. Feels like this is never gonna get fixed, its probably really easy but not at all in the priority chain.

Any update? I have the same problem.

Hello,

I got the same problem in African Clearings. Out of the 4 games I played on this map, 3 can be rewatched just fine and the fourth fails with an “out of sync” error. I don’t know if it’s related but only in the problematic game our town centers were very close and there was a villager fight. The faulty game was played today so no version problem.

Game version: 101.101.59165.0
Platform: Steam.
OS: Windows 10.
Replay: https://aoe.ms/replay/?gameId=151811562&profileId=2609771 (“new users cannot add attachment” so I put a link instead.)

I verified the game files integrity and tried again without any mod installed. The replay still fails.

Interestingly, aoe2insights which has an “analysis” tab where you can watch the replay on the minimap is not affected and works fine with that specific game.

Are those games lost forever by the way? If a bugfix comes, it will be added in a patch along other changes so the “out of sync error” will disappear but the “replay comes from an older version” will replace it.

I am getting the same error on the African Clearing map

1 Like

This just happened to me with a nomad start on MegaRandom. I’d attach the replay, but I’m not allowed to as a new user.

1 Like

Same trouble on nomad
aaaa2.101.59165.0 @2022.04.14 163020 (4).aoe2record (1.5 MB)


.

1 Like