Scenario editor crashing

Heya, I tried the scenario editor in AOE2 DE for the first time today and was able to crash it ~4 times in about 15 minutes. Unfortunately it seems a bit random, though I did manage to narrow it down to these steps:

  • Create new scenario
  • Place some butterflies (the first one in the list as Gaia)
  • Drag the rectangle on the minimap erratically for a bit
  • Usually it crashes in few seconds after that, though once I tried it wouldn’t crash until I alt tabed away from aoe and back and dragged the minimap map again.

Not sure if it helps any but this is one of the crash event logs:

Log Name:      Application
Source:        Application Error
Date:          15.11.2019 15:47:04
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      DESKTOP-MARTIN
Faulting application name: AoE2DE_s.exe, version: 101.101.32875.0, time stamp: 0x5dce4e14
Faulting module name: AoE2DE_s.exe, version: 101.101.32875.0, time stamp: 0x5dce4e14
Exception code: 0xc000041d
Fault offset: 0x0000000000b3b2a0
Faulting process id: 0x20b4
Faulting application start time: 0x01d59bc34ab2af56
Faulting application path: D:\SteamLibrary\steamapps\common\AoE2DE\AoE2DE_s.exe
Faulting module path: D:\SteamLibrary\steamapps\common\AoE2DE\AoE2DE_s.exe
Report Id: c7cf38d1-3ecf-4ea1-83da-c706d4331722
Faulting package full name: 
Faulting package-relative application ID:
1 Like

I have the same problem, the game would crash when I select butterflies.

Have had lots of crashes by now.
Crashed at seagulls
Crashed at smoke (but not before)
Crashed while scrolling through gaia other units.
It seems to me like the crashing happens more often when at the end of the map, in the black/fog area.

Man this stinks, I don’t want to keep on pressing save every single time when I change something.

i made a simple test, made 12 cavalry archers, attacked a town center and game crashed not even using butterflies or seagulls or smoke